14

Not appreciating the letter 'g' is is of course a problem. And I'm glad this has been resolved. Whether I appreciate the solution however, I'm not certain. ;)

enter image description here

It now seems the lines are overlapping completely in the Flagged Posts list for the "other" flags with a description. Of course this is consistent, but I'm not sure it's a great feature. :)

I'm on Chrome Version 27.0.1453.94 m, on Windows 7 if it matters. I have no ad-ons or user scripts installed. The same effect shows on

  • Stack Overflow
  • Meta Stack Overflow
  • Gamedev SE
  • Programmers SE

On other accounts I don't have multi-line flag messages, but I would assume the result to be the same.

Updating to Version 27.0.1453.110 m just now, the problem remains.

  • 1
    Try using a smaller font in your browser ;) – Daniel Fischer Jun 4 '13 at 9:28
  • 1
    @DanielFischer Or maybe it's a hint and I should just type less.... – Bart Jun 4 '13 at 9:30
  • 1
    You do realize we are special casing for you? – Oded Jun 4 '13 at 9:33
  • That would be only a partial workaround, though. Sometimes you need to type more for an "other" flag. A small enough font works for all lengths. – Daniel Fischer Jun 4 '13 at 9:33
  • 6
    @Oded I had that suspicion when I couldn't disable the big orange banner saying "We don't like you. We really really don't like you" at the top of my screen. – Bart Jun 4 '13 at 9:34
  • 1
    The g problem also happens here on Bart's comment (but only on small scale). Note the grey highlight on the name of the author and big. (I am on Firefox 21 btw) – nhahtdh Jun 4 '13 at 9:37
  • The bottom line just gets hungry. You should feed it more often. – SomeShinyObject Jun 4 '13 at 12:00
  • @Bart, on what site did you see this? I just checked the SO flags queue and found several multi-line comments that looked as they should, using Chrome 27.0.1453.94 m on Windows 7. – Ben Collins Jun 4 '13 at 16:37
  • @BenCollins On Meta and SO proper, as well as the Gamedev SE and Programmers SE. My other accounts don't have multi-line flag messages. I see the same at home and at work (Both on Windows 7). I'm running no ad-ons or user scripts. Chrome just updated to Version 27.0.1453.110 m for me, but the problem remains. – Bart Jun 4 '13 at 17:45
4

This issue is resolved. Obviously, you picked up on the fact that line-height wasn't being set sensibly. It is now, and it should give more consistent results across browser/os combinations.

  • Yep, looking good now. Thanks for that. :) – Bart Jun 4 '13 at 21:49
  • I see this still occurring on meta and SO, though the severity has been reduced to the level of unpopular Gs. Chrome 27.0.1453.110m on WinXP, no scripts or extensions. – Esoteric Screen Name Jun 10 '13 at 19:09
  • @EsotericScreenName sorry. I don't see it (Chrome on Windows). – Ben Collins Jun 11 '13 at 18:56
5

I'll post an answer here (since my question with more details is probably soon to be closed) as suggestion for quick/possible fixes.

I've just ran into a Suggested Edit which present the same issue. The comment is barely readable, given that the 2nd (and subsequent) lines overlap half of the previous. This phenomenon also happens in the individual revision page.


The issue seems to be the CSS applied to the body element: line-height: 1;.

Disabling/removing this entry makes the comment expand properly (along with several other element sizing on the page). Here's a screenshot showing the correct-looking comment:

Screenshot showing the proper look


An alternative solution (so as to not mess with the rest of the design) is to add line-height: 1.4em; to the revision-comment CSS class.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .