I noticed now that Stack Overflow has its padding set to 0, unlike before.

Note the padding on left side of the page; it looks shifted to the left and everything is touching the left-hand side of the screen.

Edit: Back to normal on mobile (iPhone 4 v6.1.3 / Safari).

Edit: Same problem on mobile full site version, mobile version is fine (iPhone 5 v6.1.4 / Safari).


  • 2
    I noticed this on the iPhone about yesterday as well. It's most apparent on user profiles.
    – Mysticial
    Commented Jun 19, 2013 at 15:54
  • Note that I can reproduce this here on Meta, which similarly has the padding of 0.
    – animuson StaffMod
    Commented Jun 19, 2013 at 16:26
  • Yup, on iPhone as well. But desktop (chrome) it's fine.
    – Omar
    Commented Jun 19, 2013 at 16:42
  • @animuson: On an iPad too? How much padding did it have before?
    – Ry-
    Commented Jun 21, 2013 at 13:37
  • 1
    @minitechη: All devices. This is the main site, and uses the same CSS for everything. You can use your web browser on a desktop to reproduce this - just make the window really small. It's not a mobile bug. :)
    – animuson StaffMod
    Commented Jun 21, 2013 at 16:50
  • @animuson: Oh. I thought that was the way it always was…
    – Ry-
    Commented Jun 21, 2013 at 17:14
  • 1
    This problem is in desktop browsers too. resize your window width to 977px or less. (there will be a scrollbar, but there is no padding at the left...)
    – bwoebi
    Commented Jun 23, 2013 at 9:57
  • @bwoebi true, but this problem is recent.
    – Omar
    Commented Jun 23, 2013 at 12:53
  • 2
    That's what happens when the Stack Exchange team starts exercising regularly and eating more healthily. :D
    – user164207
    Commented Jul 2, 2013 at 22:02
  • This is a preference, not a bug. It uses the full width of a narrow window. Where's the issue? It's just not broken. It might not be very pretty, but it's not a bug.
    – AndrewC
    Commented Jul 3, 2013 at 1:08
  • @AndrewC it never been like this before, it happened recently.
    – Omar
    Commented Jul 3, 2013 at 5:28

2 Answers 2


Hey Omar I heard you like padding so I made you a SO padding bookmarklet.

Just drag it the code to your favorites bookmark bar and click when ever you feel the need for padding!

javascript:(function(){var body=document.getElementsByTagName('body');body[0].style['padding']="0 1em";})()

You can later change bookmark name. SO prevents JS links.

  • 3
    This is a hack, and a hack is never a solution :) This problem doesn't affect me only, it affects all visitors/users.
    – Omar
    Commented Jun 21, 2013 at 13:39
  • 2
    All users can enjoy my so called hack.
    – raam86
    Commented Jul 9, 2013 at 12:49

The padding is set to 0, probably to make mobile interface easier to interact with.

Mobile users, particularly those with touch devices benefit heavly from larger font size, buttons, etc and one way to achieve that is setting padding to 0

  • 2
    It was working fine before, it looks different now. Thanks for your input.
    – Omar
    Commented Jun 21, 2013 at 11:21
  • How does zero padding lead to a bigger font size?
    – Pekka
    Commented Jun 21, 2013 at 12:37
  • 2
    if you have less spacing then you can use more space with text. it's simple logic... Commented Jun 21, 2013 at 13:15
  • 1
    But it makes the mobile interface more difficult to interact with, as important UI elements move towards the edge of the screen where they are more difficult to tap. This looks like a bug.
    – Pekka
    Commented Jun 23, 2013 at 7:46

Not the answer you're looking for? Browse other questions tagged .