6

For about 2 weeks, multiple people (around 10 that I know of) in our company are having trouble accessing Stack Overflow; independently of the browser, and on Linux as well as Windows. The symptom is that assets loaded from cdn.sstatic.net keep waiting forever or until they time out.

On my machine the status is that at some point those requests time out and a version of the page without any images or CSS appears.

For some Windows users reboots help, for others it doesn't.

Meta Stack Overflow (now Meta Stack Exchange) always loaded for me.

A workaround for my machine was to disable IPv6 temporarily on Linux with the command echo 1 | sudo tee /proc/sys/net/ipv6/conf/all/disable_ipv6.

Note that no other site (that I visit) has been affected like this.

Update 2013-08-12: our network guy did some checking and insists the problem lies with Cloudflare. We seem to have issues when trying to connect to them with IPv6. We can't go around and disable our IPv6 Support since we need it for our internal infrastructure. We employ the following workaround (sadly only works with Firefox):

  1. Go to about:config
  2. find the configuration key called network.dns.ipv4OnlyDomains
  3. Set it to the following list of domains (or add them if you already have something in this key): cdn.sstatic.net,www.cloudflare.net,cdn-careers.sstatic.net
5
  • 4
    Sounds more like a problem in your network, to be honest. Commented Jun 20, 2013 at 7:19
  • 1
    Well, that's what it sounds like. But given that this only occurs with Stackoverflow and that IPv6 seems to be a factor and the many reports on meta regarding similar issues, it seemed fair that I would attempt to sollicit feedback from the admins. Commented Jun 27, 2013 at 7:25
  • Does host -t AAAA cdn.sstatic.net resolve okay? If not, does using Google's DNS help, host -t AAAA cdn.sstatic.net 8.8.8.8? (Note that Meta does not use the CDN. Nice workaround!)
    – Arjan
    Commented Aug 12, 2013 at 15:36
  • (Or, for Windows: nslookup -t=AAAA cdn.sstatic.net and nslookup -t=AAAA cdn.sstatic.net 8.8.8.8)
    – Arjan
    Commented Aug 12, 2013 at 16:04
  • host -t AAAA cdn.sstatic.net seems to work fine, output: cdn.sstatic.net is an alias for sstatic.net.cdn.cloudflare.net. sstatic.net.cdn.cloudflare.net has IPv6 address 2400:cb00:2048:1::be5d:f43a sstatic.net.cdn.cloudflare.net has IPv6 address 2400:cb00:2048:1::be5d:f53a sstatic.net.cdn.cloudflare.net has IPv6 address 2400:cb00:2048:1::be5d:f63a sstatic.net.cdn.cloudflare.net has IPv6 address 2400:cb00:2048:1::be5d:f73a sstatic.net.cdn.cloudflare.net has IPv6 address 2400:cb00:2048:1::8d65:723b Commented Aug 14, 2013 at 6:47

3 Answers 3

8

Can you provide us with details on your IPv6 address and network setup to [email protected] - ask for it to be forwarded to Nick Craver and I'll take a look.

We've seen a few reports of IPv6 DNS request issues related to the new CDN, we're working with them on a resolution.

5
  • 1
    Congrats for the new avatar, I see the kid is growing up! :) Commented Jun 20, 2013 at 12:58
  • Sent the Details to [email protected] and the problem persist across the company. If you need anything in addition to debug, please let me know. Commented Jun 27, 2013 at 7:23
  • @Nick, just in case you missed it, and just in case it helps future investigations: see erpel's answer about MTU settings.
    – Arjan
    Commented Aug 26, 2013 at 7:27
  • Any updates on this? I'm getting the same behavior (requests just stay open until they time out) still. Disabling IPv6 completely "solves" it...
    – James B
    Commented Oct 6, 2013 at 8:42
  • I've been getting this for the last few weeks on my Windows 8 laptop. I disabled IPv6 in Firefox per the instructions above and it worked. Commented Feb 9, 2014 at 22:31
1

For me, DNS always looked fine, but I also never got any http responses back from the CDN hosts.

Lowering the MTU on my tunnel interface from 1500 to 1300 restored stackoverflow availability instantly.

This could serve as a workaround but is also something that one might want to look at on the hosting site.

For info, traces, address information please feel free to contact me.

1
  • Nice. Do you recall the initial value of your MTU? Just for future reference, I've been on native IPv6 for years, and the Wifi on my Mac uses MTU 1500. My Fritz!BOX VDSL modem has MTU set to automatic, and is currently at 1500 as well. I never had any issues.
    – Arjan
    Commented Aug 26, 2013 at 7:26
0

I had this problem.

After digging into my firewall, I discovered that the IPv4 addresses for cdn.sstatic.net were on my bogons list. My firewall's bogon-blocking list had become out-of-date.

So, update your blocked-bogons list, or turn off bogon filtering in your firewall, and cdn.sstatic.net becomes reachable.

Team CYMRU maintains downloadable IPv4 and IPv6 bogon lists that can be loaded directly into a pf table.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .