5

I am trying to use Stack Overflow from an ipv6 enabled site (2001:6f8:1c3c::1/48), with the following problem: The server cdn.sstatic.net has multiple ipv6 addresses, which ping but seem not to answer to http requests. Since this blocks the render process, it takes 60 seconds before Stack Overflow appears (but without styles).

I tried to fetch the file with curl:

# curl -vi "http://cdn.sstatic.net/stackoverflow/all.css?v=5fb38a3dda0b"      
* Adding handle: conn: 0x101aeb0
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x101aeb0) send_pipe: 1, recv_pipe: 0
* About to connect() to cdn.sstatic.net port 80 (#0)
*   Trying 2400:cb00:2048:1::be5d:f43a...
* Connected to cdn.sstatic.net (2400:cb00:2048:1::be5d:f43a) port 80 (#0)
> GET /stackoverflow/all.css?v=5fb38a3dda0b HTTP/1.1
> User-Agent: curl/7.30.0
> Host: cdn.sstatic.net
> Accept: */*
> 
* Recv failure: Connection timed out
* Closing connection 0
curl: (56) Recv failure: Connection timed out

Meta Stack Overflow works by the way.

7
  • 1
    Meta doesn't use a CDN for its CSS, which is why you don't see the problem here. – Martijn Pieters Jun 27 '13 at 13:48
  • 1
    Thanks for the report, we'll relay to the CloudFlare team who are tracking these down. – Nick Craver Jun 27 '13 at 13:54
  • @Nick, no problems from Amsterdam: About to connect() to cdn.sstatic.net port 80 (#0) Trying 2400:cb00:2048:1::be5d:f53a... connected Connected to cdn.sstatic.net (2400:cb00:2048:1::be5d:f53a) port 80 (#0). (debug-02.netdna-cdn.com reports "You are hitting the NetDNA Amsterdam Datacenter", but that always seems to use IPv4; 108.161.189.192) – Arjan Jun 27 '13 at 16:04
  • Connection seems not to be the problem from here to. But after connect no data is send or received. – plain Jun 27 '13 at 16:08
  • Sorry, I should have mentioned: I do get the CSS. I only copied the parts that showed the IP address. ;-) – Arjan Jun 27 '13 at 16:14
  • We're having the same issue - having to disable IPv6 on machines, as StackOverflow (and anything else using CloudeFlare CDN) fails to load :( – Danny Tuppeny Sep 10 '13 at 8:56
  • I had similar problem with time out, but on IPv4. After short time it worked by it-self. – kenorb Jul 2 '14 at 9:37
1

I was having the same problems when I turn my IPv6 enabled layer 2 VPN on. Lowering the MTU on the tunnel interface to 1300 worked as a workaround for me, maybe you see if it does anything for your situation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .