21

It looks as if the 10k-tools flagged post list is b0rken.

Next to the review link in the toolbar there is a flag counter showing there are 10 flags to be reviewed:

flag counter

Clicking on that flag counter leads to an empty page:

empty flags page

The moment I visit that page (through clicking on the flags counter, or by going to the review queue first then clicking on Tools, selecting the flags tab if not already selected), the flags counter disappears from the toolbar:

no indicator anymore

but after a while (half an hour, an hour?) the flag count re-appears in the toolbar.

Either the counter is wrong (presumably taken from a Redis cache somewhere) or the 10k flag review page is falling over every time someone tries to load it.

This at first appeared to happen only on Meta, on Stack Overflow the flags page has plenty to review. However, there are now reports of other mishaps with the same page on Stack Overflow.

10
  • It's interesting that the issue is reported twice at the same time.
    – Antony
    Jul 3, 2013 at 15:24
  • 2
    It is interesting, because I have been running into this for a while now and only just now decided I had the time and inclination to post a report. Bart already removed his dupe. Jul 3, 2013 at 15:25
  • 1
    Great minds think alike @Antony. Well, a great mind and the mumbling idiot who came in 2 minutes too late.
    – Bart
    Jul 3, 2013 at 15:26
  • 1
    @Bart: But it was you who came in 2 minutes late with the post, not me.... Jul 3, 2013 at 15:29
  • I have seen this 5 or 6 times on Meta. FWIW it is always 10 flags. Jul 3, 2013 at 17:03
  • Just saw 11 flags, I have seen 12 before. Jul 3, 2013 at 17:03
  • Yay, it was now down to 6 flags, and when I clicked it I saw one flagged post! Progress! Jul 3, 2013 at 17:46
  • today it seems to always be 8 flags for me Jul 4, 2013 at 12:55
  • @KateGregory: I see 9 right now, but saw 7 and 8 before. It varies. They are never there when you click on them. Jul 4, 2013 at 13:04
  • My guess is those are comment flags waiting patiently in the queue. OK, just flagged a comment let's see if the number rise to 9. :) Jul 4, 2013 at 14:35

2 Answers 2

5

There was a rogue query for 10K users that didn't get the proper treatment, specifically the top bar's count was including flags that only moderators could see.

This has been fixed and deployed.

Let me know if the counts are looking off again for extended periods (if it's fleeting, it's just cache invalidation across all servers).

8
  • Do you (devs) retag the duplicate bug report too (with status-completed/declined)? Or we just leave it as it is.
    – Himanshu
    Jul 9, 2013 at 7:21
  • 2
    It's however the mood strikes me :) It's probably better if I do retag the dupe, at least to notify the author. Jul 9, 2013 at 7:23
  • At least on SO the issue that I outlined below is still happening. The right column on the flag queue for NAA shows more items in the queue then are being displayed in the page.
    – Taryn
    Jul 12, 2013 at 14:19
  • We had one flagged answer today, and I reviewed the flag in the 10k+ tools. The [1] indicator in the top bar keeps lingering though, hours after I looked at that flagged answer. It seems as if the cache invalidation is not working so well. Jul 22, 2013 at 14:33
  • We are seeing the return of the problem across the SE network; clearly something got stuck again. Jul 22, 2013 at 14:59
  • For now, on Meta at least, things have cleared. Perhaps it was a temporary problem? Jul 22, 2013 at 16:09
  • @MartijnPieters it was a bug; I deployed a fix. Jul 22, 2013 at 17:03
  • This still seems to be there Sep 11, 2013 at 19:53
2

I have am also seeing this on Stack Overflow. If I go into the Not an Answer review queue, I am being shown a total of 32+ items to review but the queue is empty.

enter image description here

I have seen this in multiple browsers (Firefox/Chrome on Mac/Win).

3
  • Note that on Meta, there are no filters at all on the right-hand side. I do believe the two issues are one and the same though. Stack Overflow manifests it slightly different because it has more flags to process, is my guess. Jul 3, 2013 at 16:27
  • @MartijnPieters Yeah, it probably is the same issue that is why I deleted my question and posted this here. It took me a while to get through the NAA review queue and it consistently stayed at 32+ even though I wasn't being shown 32 items for review. I waited to see if it was a cacheing issue, but the total never changed.
    – Taryn
    Jul 3, 2013 at 16:32
  • @JarrodDixon I'm getting a similar issue over in physics.se.
    – E.P.
    Sep 11, 2013 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .