7

Starting yesterday, pages on Stack Overflow have been coming up as text and links only, no images or CSS. It is only doing this in Chrome, and only for stackoverflow.com.

Chrome developer tools console shows the following:

Failed to load resource https://cdn.sstatic.net/stackoverflow/all.css?v=da12668b668c
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:18
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:35
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:40
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:261
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:375
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:388
Failed to load resource https://cdn.sstatic.net/js/stub.js?v=dd6898efd655
Uncaught ReferenceError: StackExchange is not defined dynamic-dependency-injection:467

Example of a URL that shows the error: Link to Sitecore Media Item

I don't have adblock or JavaScript blocked. Is this a browser issue? I'm using Chrome Version 28.0.1500.72 m on Windows 7 Enterprise with SP1, 64 bit.

  • Happening here(Auburn Hills, MI) too for roughly the last week. Edit...as I typed, it started working. – Brandon Jul 16 '13 at 15:44
  • That happened for me briefly in Chrome yesterday, then by the time I got home (a few hours later) it worked fine. Perhaps a particular version. I'm on 27.0.1453.116 m still, though, same as I was the day it happened. – Joe Jul 16 '13 at 16:18
  • Not happening for me – Dynamic Jul 16 '13 at 16:44
  • ...And my issue is back – Brandon Jul 18 '13 at 18:13
  • 1
    Are you, by chance, behind an iPrisim filter? – PaulH Jul 18 '13 at 18:23
  • @PaulH I am experiencing this issue, and yes, I am behind an IPrism. – DCNYAM Jul 19 '13 at 12:51
  • I suspect it's an interaction between chrome and iprism that causes this. There was a similar issue last year: code.google.com/p/chromium/issues/detail?id=130293 – PaulH Jul 19 '13 at 13:36
  • @PaulH I am behind iPrism as well. After looking at the thread you posted, I tried launching chrome with the "--disable-tls1" flag and I'm still seeing the error. I'll talk with our Security manager to try to see if there is something in iPrism that can be corrected. – Ian Akori Jul 19 '13 at 20:28
  • It happens quite frequently recently. Now stackoverflow is not showing properly now.. – Annie Kim Jul 21 '13 at 3:53
  • @Ian Akori If you and your admin find the answer, please post it here. I would like to pass it to my admin as well. – PaulH Jul 24 '13 at 2:13
  • @PaulH will do. I have put in a request for him to look into it. waiting to get a response. I'll update here when I get a reply. – Ian Akori Jul 25 '13 at 16:48
  • It looks like this has been fixed (for me, at least). I notice the css content that was previously at "https: //sstatic.net/..." is now at "//sstatic.net" and any attempt to access SO over https redirects to the http connection. – PaulH Aug 7 '13 at 16:53
3

We also had this issue and are using iPrism. According to our admin, he was able to fix this issue by applying one of the latest patches to the iPrism system. I've yet to see the issue reappear since he told me the patch was applied.

  • Fixed for me after the latest iPrism patch. Marked as answer. Thanks to PaulH for the tipoff. – Ian Akori Aug 19 '13 at 3:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .