7

In my Stack Overflow profile we can see that Citizen Patrol badge is there. Now I have same badge on meta site too but instead of showing this badge in my meta profile, it is showing here.

Is this a bug or ?

  • 1
    It should show in both pages. It is a bug. – hims056 Jul 17 '13 at 10:22
  • @hims056 - The user profile is cached. For 10 minutes, IIRC. – Oded Jul 17 '13 at 10:23
  • 1
    @Oded 10 Mins ?? I raised my first flag on 12th July. Currently I have 25 helpful flags in my profile, and I am on the way to earn Deputy Badge in few days – Vigbyor Jul 17 '13 at 10:24
  • When were you awarded the badge? – Oded Jul 17 '13 at 10:25
  • @Oded - also see this: meta.stackexchange.com/q/188930/187824 – hims056 Jul 17 '13 at 10:25
  • @Oded , I dont know, Moderator Mosa just showed me that link. – Vigbyor Jul 17 '13 at 10:27
  • Interesting. In the particular badge page for any user it shows timestamp of when it was awarded. E.g. myself. But there is no timestamp in yours – hims056 Jul 17 '13 at 10:31
  • @hims056, Thanks, its good point or may be another bug. – Vigbyor Jul 17 '13 at 10:33
  • 8
    caching, a proven way to optimize user complaints. - It doesn't work!!! - Probably caching, wait for 5 minutes. - It doesn't work!! - Probably caching, wait for 5 minutes. - It doesn't work! - Probably caching, wait for 5 minutes. - It doesn't work. - Probably caching, wait for 5 minutes. - It doesn't matter. – gnat Jul 17 '13 at 10:37
  • @Vigbyor I bet you never flagged a post here on Meta. Is this correct? – Shadow The Burning Wizard Jul 17 '13 at 10:53
  • 1
    OK, the bug is in the citizen patrol page when it has a user ID it will always show as if the user got the badge. This is proof enough - user with only 1 reputation while one needs 15 points to flag. @Oded to your attention as well. – Shadow The Burning Wizard Jul 17 '13 at 10:55
  • 2
    oh Man, I am confused ? have I earned the badge or not ??? – Vigbyor Jul 17 '13 at 10:58
  • 2
    Well, you found two bugs that's quite impressive! One bug is no badge even though you should have earned it and another one that you discovered by chance. – Shadow The Burning Wizard Jul 17 '13 at 10:59
  • 2
    @Vigbyor - You did not earn the badge, though you should have. In that respect, your profile page is correct, but the single badge page is not (as things stand). Once the badge is awarded, both pages should show it. – Oded Jul 17 '13 at 10:59
  • 1
    @Oded ha ha that means Mosa just fooled me by showing that link :P – Vigbyor Jul 17 '13 at 11:00
5

There is a bug on the single badge page. It is showing that you have earned the badge when, in fact you didn't.

For example, you did not earn the Publicist badge:

https://meta.stackoverflow.com/help/badges/76/publicist?userId=227860

It appears that if a valid userId is passed in to the page, the words "earned this badge" show up, whether one did or did not. However, if the badge had been awarded, a date will also appear.

This will be fixed soon.

  • I wonder what is the expected behavior though? Showing "this user did not earn this badge", or just redirecting to the badge page? – Shadow The Burning Wizard Jul 17 '13 at 11:05
  • 1
    @ShaWizDowArd - I would say - did not earn sounds moar correkt – Oded Jul 17 '13 at 11:06
  • @Oded or I would say, showing a "" blank space is better. – Vigbyor Jul 17 '13 at 11:07
  • 1
    @Vigbyor - Having words makes sure the page is not ambiguous. – Oded Jul 17 '13 at 11:08
  • @Oded agree but displaying negative message ( did not earn ) doesn't sound good user interface as per my experience. – Vigbyor Jul 17 '13 at 11:09
  • 1
    @Vigbyor - true enough. "Yet to be earned" ;) – Oded Jul 17 '13 at 11:11
4

Please refer to @Oded's answer for details.

The bug is fixed and it will be out in the next deployment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .