18

As far as I can tell, whenever I try to submit an answer with Ctrl + Enter, it doesn't work. As this is allowed on edits, reviews, and question asks I would be very happy to see this on answers too.

10
  • 5
    Is that supposed to work? I don't think I've ever heard of that Jul 17, 2013 at 16:52
  • 4
    @MichaelMrozek Works with edit, ask (iirc) + review. Jul 17, 2013 at 16:53
  • Definitely not bug...
    – Mooseman
    Jul 17, 2013 at 16:54
  • 2
    @Mooseman Huh? This works on (most) other SO forms... Jul 17, 2013 at 16:56
  • 23
    Perhaps it's a bit of a nudge to users that they ought to think a little more about their answers before summarily posting them with a hot-key to save 500 milliseconds.
    – user102937
    Jul 17, 2013 at 17:09
  • 1
    It indeed works on questions/edit. Reproduced on the sandbox. Jul 17, 2013 at 17:14
  • 6
    @RobertHarvey Why is it allowed on questions then?? Jul 17, 2013 at 17:38
  • @newStackExchangeInstance I believe this is either feature-request or status-bydesign.
    – Mooseman
    Jul 18, 2013 at 11:52
  • i dont see why is that important you can always use the button [ Post Your Answer ] .. not that hard to move the mouse and click it :D Jul 18, 2013 at 12:53
  • 1
    It isn't: it's just a small convenience that I would appreciate. Jul 18, 2013 at 12:57

3 Answers 3

12

We already have keyboard shortcuts for most actions on post, voting, flagging/moderating, editing, etc. and the shortcut is already enabled for post edition. Seems easy to just allow post submission, no?

Also, it's annoying to reach for the mouse just to submit your answer :(

6

tab+enter already works; why have another shortcut for it?

1
1

If you can see this, I successfully submitted this answer by pressing Ctrl + Enter, thanks to the SE like I like it user script. I got a “Do you want to leave this page?”, but apart from that it worked fine.

7
  • You sure? I've tried Ctrl+Enter and Shift+Enter at the sandbox, nuthin'.
    – Ollie
    Jul 1, 2021 at 16:56
  • Yes, I tested it with this very answer and have been using it like since I can think. Could be browser- and settings-specific though.
    – Wrzlprmft
    Jul 1, 2021 at 17:00
  • @Ollie Same. I can't get it to work at the sandbox. Not in Mardown mode, not in RT mode, and not even using the old editor.
    – 41686d6564
    Jul 1, 2021 at 17:01
  • @Wrzlprmft What browser are you using? I tested it on Chrome on Windows.
    – 41686d6564
    Jul 1, 2021 at 17:01
  • @41686d6564: Firefox on Linux (with Tridactyl, but that doesn’t seem to occupy that shortcut).
    – Wrzlprmft
    Jul 1, 2021 at 17:03
  • @Wrzlprmft I can't get it to work even in Firefox.
    – Ollie
    Jul 1, 2021 at 17:08
  • @Ollie: I found the culprit. See my edit.
    – Wrzlprmft
    Jul 1, 2021 at 17:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .