Wrote text in an rtl language (from the context of the question you can see it is done with good reason). I then tried to make bold one letter within the word, while making the entire word in italics -> example.

As you can see, it's actually not connected to the orientation of the language.

  • Some of the text shows as bold in preview but has *s after. Probably due to the different text direction. – Greg Aug 30 '09 at 22:39
  • Could this be another reason why SOFU is EN-only? – Mark Henderson Aug 30 '09 at 22:42
  • 3
    @Farseeker. No, it isn't. It's not like English speaking programmers don't have to deal with internationalisation issues. – therefromhere Aug 30 '09 at 22:59
  • 1
    Hmm, good point (I reside on SF, not many multilingual issues happen there) – Mark Henderson Aug 30 '09 at 23:03
  • *exa*​*m*​ple ​ – Brad Gilbert Aug 31 '09 at 14:44
  • 3
    WMD? Weapons of mass destruction? – Colonel Panic Sep 10 '12 at 19:51
  • yes - (but, in case u where serious, it is the text editor we use in this site) – Itay Moav -Malimovka Sep 10 '12 at 20:11
  • @Mark — What is “SOFU” ? – Nicolas Barbulesco Jan 3 '14 at 9:56
  • @Mark — By the way, now we have french.stackexchange.com. :-) – Nicolas Barbulesco Jan 3 '14 at 9:59
  • @NicolasBarbulesco - in '09 there was just Stack Overflow, Server Fault and Super User, so the collective term for the three sites was S[OFU]. Now we just call it Stack Exchange. This was also pre-Area 51 for new SE sites. – Mark Henderson Jan 3 '14 at 10:25
  • @balpha this no longer works, can you please remove the (now wrong) status-completed tag? – Shadow The Vaccinated Wizard Apr 21 '18 at 10:01
  • @ShadowWizard Can you clarify? This was completed a while ago. See the "duplicate". – balpha Apr 21 '18 at 10:03
  • @balpha oh wait... it works for letter, but not characters like comma. – Shadow The Vaccinated Wizard Apr 21 '18 at 10:04

You can use html tags like <strong> and <em> or <b> and <i> to format in those exceptional cases.



The source for that was:

  • 8
    It's not really exceptional if you write Japanese text, which does not separate words by spaces; and Japanese text is quite common on japanese.stackexchange.com – Tobias May 5 '13 at 23:58
  • 1
    @Tobias at the time of writing that, there was no Japanese site in the system. – jjnguy May 6 '13 at 15:51
  • 1
    It´s not working for comments! – Knu Oct 27 '13 at 1:35
  • 1
    This workaround does not work in comments — which is too bad. – Nicolas Barbulesco Jan 3 '14 at 10:01

We don't support intra-word emphasis. This is by design.

See the blog: Three Markdown Gotchas.

In short: if typing some_file_name would render as "somefilename", then that would bother more people than those who really need part of a word to be emphasized.

  • 5
    This makes using Markdown in Japanese (and other languages that don't use spaces) really painful. Especially surprising is that intra-word bolding works as expected in the preview pane, but not in the submitted question. See japanese.stackexchange.com/questions/11824/… for an example. – Tobias May 5 '13 at 18:52

I've come across this a few times and the solution is relatively simple...

I use a zero width Unicode character between the last asterisk and the next character -


This will also work for B​O​L​D characters...

Here is the zero width character (between the brackets).


For ease of use, I made myself a little JavaScript bookmarklet that "displays" an alert with the character inside -

javascript: alert("%E2%80%8B");


As you can see on this page (which is not cached, so it shows you what today's Markdown engine does), this now works. If someone were to edit your question, it would look correctly afterwards. For details, see Markdown change: Intra-word emphasis now works; the short version is that in-word emphasis is now allowed for asterisks, but not underscores (Jeff explained why).


I think that the most you could ask for, is for the Markdown to accept a U200B ( Zero Width Space ) character to seperate the "*" from the rest of the word. Which does actually seem to work.



  • 4
    ... but doesn't work in comments ( *exa*​**m**​ple ) – Brad Gilbert Aug 31 '09 at 14:51
  • In questions and answers, you can write it using HTML references: *exa*&#x200B;**m**&#x200B;ple. – MvG Nov 16 '12 at 21:36

You'll have to break out the HTML tags to get a bold letter inside a word. Looks like the WMD preview might be okay on the rough show, but the actual post looks like it's looking for a space on either side of the WMD markup.

  • Yes, but typing the HTML tags within the right-to-left text seems to behave strangely (or maybe that's normal, as I said this is the first time I've edited right-to-left text). – therefromhere Aug 30 '09 at 23:12
  • Even trying to select the text is a trippy experience. – random Aug 30 '09 at 23:15
  • 2
    I tried to edit it...but my computer was making me want to kill the text. – jjnguy Aug 30 '09 at 23:16

I think the bug he's referring to is that trying to produce the following: נזוןשמו

Using this markdown:


Appears with whole text in italics and the letter ש bold in the preview, but not in the posted version.

You get this instead:


Or maybe that the cursor direction reverses within the string making editing the markdown tricky - the first time I've ever edited Hebrew, that was trippy!

I'm not sure what's supposed to happen, but I couldn't edit HTML into the middle of the text (the tag was dumped to the end).

Edit: It was clarified while I was posting. Sorry for the note-as-a-answer, but considering the bug it's a pain to try and respond with a note!

I'm using Firefox 3.5 on Vista 64 by the way.


As stated above, this works using HTML - but wrapping your head around the RTL movement is a huge pain. I edited it, and I think I managed to do it without messing with the actual text.

  • More power to ya! I couldn't figure it out... – jjnguy Aug 31 '09 at 17:09

Not the answer you're looking for? Browse other questions tagged .