16

The comment with the Flagged Posts that seems to be new as of today states there are posts with flags awaiting my attention but the counter shows zero and when I go into flagged posts there is nothing waiting for me.enter image description here

9

People were (rightfully) complaining that the /tools/flagged indicator was a bit random, so I decided to always show it.

Perhaps I should have checked for a count > 0 first, though.

Fixed.

  • 2
    So you're the Dev spending a week on the mod tools. – Undo - Reinstate Monica Jul 22 '13 at 15:32
  • Shhhhhhh :) – Jarrod Dixon Jul 22 '13 at 15:35
  • 1
    I'm experiencing this now on Mi Yodeya. I have a yellow-splatted 1 on my toolbar, but there's nothing there when I click through. – Isaac Moses Jul 23 '13 at 17:58
  • @IsaacMoses, ditto. – Seth J Jul 23 '13 at 18:45
  • @JarrodDixon This issue still seems to be happening on some sites it seems. – Michael Grubey Jul 24 '13 at 7:38
  • Yeah, it's due to us caching the count globally for all users. Fixing it requires either 1) running another query on each page load for each 10K user (not acceptable) or 2) an elaborate caching scheme for each 10K user (ain't nobody got time for that :) – Jarrod Dixon Jul 25 '13 at 0:15
  • 2
    So, we're going to look at just removing that number by routing the /tools/flagged page's contents into different /review queues, e.g. low quality flags -> Low Quality Posts review queue. Discussing it now internally. – Jarrod Dixon Jul 25 '13 at 0:16

Not the answer you're looking for? Browse other questions tagged .