A couple of times recently when I attempted to edit a post while reviewing it from the "First Posts" queue, I received the following message when I tried to submit the form:

This edit would have to be a suggested edit. (x)

This is a rather cryptic message, considering that edits made from a review are suggested edits, subject to the same peer review process. There was no indication of how the edit would have to be submitted differently, much less why. I searched both help and meta for more information about this message, but came up empty.

The first time it happened, after I cancelled out I saw that someone else had just edited the post, so I thought maybe that's why I couldn't submit an edit from the review (and wondered why, if that's the case, the error message didn't just say that instead of telling me something that doesn't make any sense - that the edit I'm trying to suggest can't be submitted because it would have to be a suggested edit). However, the second time I received this message (last night, for this question: Codeigniter Uploading files into gallery folder), there was no other edit. So, I clicked the No action needed button and tried to edit the post outside the review process, only to discover that the edit link was grayed out.

I see several explanations of possible causes for graying out the edit link here: Always show the edit button on questions. However, there was no tooltip when I hovered over the disabled link, and the edit queue was in the single digits.

A few minutes later, I noticed that the edit link was no longer grayed out, so I edited the post and my edit was accepted.

My best hypothesis based on my experience with the error so far and the explanations I've read here at meta is that someone submitted a suggested edit while I was reviewing the post, which (a) caused me to get the cryptic error message and (b) caused the edit link to be grayed out when I accessed the post the normal way. Then a few minutes later, the suggested edit was rejected, opening up the question for new edit suggestions.

Rather than speculating about it and trying to determine the answer scientifically, it would be helpful if someone could give me the answer (as Seinfeld fans might put it, "Why don't you just tell me why I can't edit the post?"). It would be even more helpful if the error message itself provided the explanation, or if the message were defined somewhere in the help pages. But, at the very least, hopefully there will soon be an answer on meta to enlighten people who scratch their chins over this in the future. :)

  • Do you perhaps have the reputation for the First Posts queue, but not enough for unreveiwed edits (2000 I believe)
    – Cole Tobin
    Commented Jul 28, 2013 at 1:50
  • Yes, my current rep is 1192, but how does that explain it? I've submitted edits while reviewing a post before, and they went into the Suggested Edits queue. So what was the problem on these two occasions? And what does "would have to be a suggested edit" mean as opposed to what I was doing? AFAIK I was trying to make a suggested edit. And don't forget that the second time, I finished the review with no action and tried to edit the post outside the review process, but the edit link was grayed out for a few minutes. I suspect that there might be a connection between the two mysteries.
    – Adi Inbar
    Commented Jul 28, 2013 at 2:25
  • 2
    So, no answers at all? This seems to me like the kind of question that would have to have a definitive answer (there is a defined set of circumstances under which that error message pops up), and presumably there would be people here who know what that answer is--people who were involved in the implementation or have access to the code. So I'm wondering why the question has scrolled off into oblivion with no answers. This is my first question on meta, so maybe I did something noobish...is it because I didn't include any screen shots with freehand red circles or say anything about unicorns?
    – Adi Inbar
    Commented Jul 30, 2013 at 3:29
  • Probably low view count. Editing with a free hand circle (MS Paint plz) screenshot would bump it to the top of the home page.
    – Cole Tobin
    Commented Jul 30, 2013 at 3:51
  • 1
    @ColeJohnson sigh I'd love to be able to add a free hand red circle, but for that I'd need a screen shot, and I haven't been able to reproduce the error. I've done plenty of reviews, but very few have needed edits (more flags than anything else), and the two or three that called for edits haven't given me the mystery error. So, I have nothing to free-hand-red-circle. Too bad I was too meta-noobish when I posted this to realize that I needed the free hand red circles in the first place to get some attention around here. So, the mystery goes unsolved. :(
    – Adi Inbar
    Commented Aug 3, 2013 at 2:53
  • This message is very confusing as it blocks you from making your suggested edit without really explaining why. The message in fact seems unrelated to the reason that triggers it. Something like "A suggested review is already pending" would have stopped me scratching my head and hitting the submit button multiple times wondering what I was doing wrong.
    – Burhan Ali
    Commented Sep 12, 2013 at 23:16

1 Answer 1


When you reviewed that post, there was already another suggested edit pending for the same post. You can't suggest an edit while a previous edit is awaiting review, so the system prevented you from doing so.

Yes, that error message could have been less cryptic.

Update: The error message now tells you more accurately what's going on. This is what you should see in this scenario:

Another edit is awaiting approval for this post. Further edits cannot be submitted until the pending edit is reviewed.

  • Okay, so it was what I suspected. Thanks for confirming. BTW, the review record for the rejected edit made me raise my eyebrows. I'm glad it was rejected, but find it amusing that not only was it a 3-2 vote, all three editors who voted to reject gave "too minor" as the reason. The main problem with the edit isn't that it's too minor; it's just plain wrong! Apparently the editor doesn't realize that -> and => are atomic two-character operators in PHP, and breaking them up with whitespace would break the code. One needs to be careful when editing code in a language one doesn't know!
    – Adi Inbar
    Commented Aug 5, 2013 at 1:50
  • I am above 2000 rep, yet I still get the same error. I don't see any pending suggests, but deletions/locks seem to trigger it. Maybe at least a reword is needed, and a logic change in the next revision?
    – nanofarad
    Commented Sep 2, 2013 at 5:44
  • Idea! Why not alert the user that his or her continued editing is unnecessary as soon as another edit is submitted first? This way, the user won't have to continue wasting time proofreading a long post (which is what I just did!) only to find out that it was in vain. Less hair-pulling and more efficiency! :D
    – Yogenzaga
    Commented Oct 17, 2013 at 16:56
  • 1
    Even a simple "edit conflict" would be better. Please fix.
    – kush
    Commented Oct 29, 2013 at 10:28
  • 1
    Should be fixed now, @kush. As a bonus, it should also provide descriptive errors in other cases where you can't submit an edit for some reason (post is deleted / locked / buried in a lead-lined vault under the Gobi desert, etc.)
    – Shog9
    Commented Nov 19, 2013 at 22:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .