5

If a post has too many comments to show, first you click "show (n) more comments," then you can post your own. However, after submitting the comment, the "show (n) more comments" link reappears. Clicking it just brings up the text box.

Note that this also happens when you visit a link to a comment that should be hidden (for example, when clicking on a reply in your notifications).

This is possibly a mobile-specific bug: repro-ed on iPod Touch iOS 5.1.1 mobile Safari.

click to enlarge
image

Possibly a result of this bugfix: Add Comment disappears after editing a comment, or this one: "add comment" link disappears after voting to close a question as off topic with custom comment

  • 1
    Norepro on Chrome 28 (desktop), maybe it's a mobile-specific bug? – Old Checkmark Jul 28 '13 at 7:04
  • @Old Alright, thanks. Edited. – Doorknob Jul 28 '13 at 7:17
  • I got an imgur app :D The fact that the text overflows may be another bug - probably caused by a different comment since there are so many ridiculous comments in the sandbox – Doorknob Jul 28 '13 at 7:37
  • 1
    Reproduced in mobile version on desktop Chrome (Windows 7) – Shadow The Princess Wizard Jul 28 '13 at 7:45
  • 1
    @Sha Okay, so it's definitely a thing specific to the mobile site. – Doorknob Jul 28 '13 at 7:48
  • 1
    @Doorknob mobile theme, yes i.e. different CSS and JS files. – Shadow The Princess Wizard Jul 28 '13 at 7:49
  • Test result on mobile version on desktop Chrome: “show n more comments” does reappear, but clicking it brings up the textbox (tested this on the great croissant debate). – Old Checkmark Jul 28 '13 at 8:00
  • @Old Whoops, didn't notice that. Same happens for me. – Doorknob Jul 28 '13 at 8:43
  • No, I have seen this very often on desktop Chrome on multiple machines. I've been trying to record it for posterity but it never seems to happen when I have Camtasia open. – Aaron Bertrand Aug 9 '13 at 19:15
2

This looks mobile-specific (like the commenters already figured out). I'll try to get to this soon; I'll update this answer when I have something to report. In the meantime, a simple workaround is a refresh.

Update: This should be fixed now. I'm using a hidden tag to swap out the text of the link after various interactions. The problem was that the mobile site gets different markup and that hidden tag wasn't getting rendered, so when it came time to swap in the different text, there was nothing there.

  • Why would I refresh? Basically what happens is that the "add comment" text gets replaced by the "n more comments" text - nothing that would prevent me from commenting again or anything. – Doorknob Jul 29 '13 at 23:14
  • 1
    @Doorknob: If you really, really want to see the comment link text rendered correctly :-) There's no functional impact. – Ben Collins Jul 30 '13 at 14:19
  • Ben, did this fix only occur in code that would be presented to mobile devices? I've been seeing a similar issue (intermittently) on desktop, so I'm curious if the actual code would affect everyone (and hence why I'm suddenly unable to repro). – Aaron Bertrand Aug 9 '13 at 20:08
  • @AaronBertrand I made a similar change for both. – Ben Collins Aug 9 '13 at 21:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .