4

I wrote this SEDE query (that shows how old the last migration is).

But when I execute it, it always shows the same, presumably cached, result. The result is always as it was when the query was last updated.

I assume it has something to do with it being a fixed query (no parameters).

Is there a way to force it to get fresh results when I re-run it?


Update: Although the query is static, the results are not: The query returns dynamic data (how many days ago the migration was run), so to be correct it needs to be re-run every time.


Feature request:

Can we have an option to not cache the results for cases like this?

2
  • Off-hand, I don't see us adding an option to disable caching because that could be misused very quickly on queries that really should have their results cached. But out of curiosity, what do you use this query for? – Adam Lear Jul 29 '13 at 2:35
  • @AnnaLear I wanted to show how old the last migration was in days, mainly because my tiny brain can not easily subtract dates. It was just a "nice to have". – Bohemian Jul 29 '13 at 3:07
3

Can we have an option to not cache the results for cases like this?

No, for the reasons that Anna Lear described. Data Explorer already has an option to disable caching across the board, which can be configured in appropriate environments. Naturally the public SEDE instance is not one of those.

For cases like this, I think it would be better to introduce a new magic column or special result set syntax that simply calculated the dynamic offset values client-side against the cached static result set. That way everyone gets what they want, and the server stays happy.

Of course, this wouldn't resolve the same sort of issue for queries that use functions like RAND(), but I don't think I've run into a very compelling case where that'd be a problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .