18

Recently, I have been chatting on my mobile device more frequently, and have noticed a slight error in the way that thumbnails of Oneboxed videos are displayed. I tried to post a mobile video, using the m. prefix instead of the www. prefix, and it was only displayed as a link to the video, instead of a thumbnail.

The point is that if you post a video as www.youtube.com/***, it renders a thumbnail of the video, but if you post a mobile video as m.youtube.com/* it renders a link to the video, not a thumbnail of if.

For example:

http://www.youtube.com/watch?v=ZlcscBCW4DQ would correctly Onebox in chat,

but:

http://m.youtube.com/watch?v=ZlcscBCW4DQ wouldn't.

Proposed Solution: Write a few lines of code into the API that would automatically change the address's prefix to www. from the mobile prefix, m., which would enable the video to be oneboxed correctly.

Thank you to everyone who upvoted and supported this. Also, thank you to the SE employees who made this possible! Image to Support Example

5
  • 3
    I'd rather see it translated differently based on the viewer Aug 2, 2013 at 17:57
  • Why the bounty?
    – balpha Staff
    Aug 5, 2013 at 13:59
  • @balpha I wanted to see if this would ever be answered either with as reason for why it isn't viable, which I think it is, or with an answer declaring thisn completed. Also, it will most likely get more attention, aka more upvotes, aka more support from the community.
    – Pip
    Aug 5, 2013 at 14:15
  • Seriously, you post a minor issue on Friday, and then on Monday complain that it isn't fixed yet? Sure, it's a valid point and not a hard fix, but don't you think you're being out of proportions here? Also see point 1 at meta.stackexchange.com/questions/128818/….
    – balpha Staff
    Aug 5, 2013 at 14:47
  • @balpha I'm not complaining... I just hope it will be fixed soon
    – Pip
    Aug 5, 2013 at 14:48

0

You must log in to answer this question.

Browse other questions tagged .