2

I was viewing my private profile (now public) by clicking "employer view" on the right and noticed some things I would consider to be bugs. These issues do not occur after making your profile public.

  1. The Top Answers section lists the highest-voted seven answers, but ordered ascending rather than descending by number of votes. i.e. "3, 3, 3, 4, 6, 6, 9" rather than "9, 6, 6, 4, 3, 3, 3". (akin to SELECT * FROM (SELECT * FROM answers WHERE user_id=760706 ORDER BY votes DESC LIMIT 7) AS t ORDER BY votes ASC in SQL, instead of just the inner query as I would expect)
  2. One of my answers is to a question, the first char of which is a less-than sign (it's a question about HTML tags). This page is not escaping the less-than sign to < causing the whole question title to be absent!
  3. My profile is missing my user image. If I have uploaded a custom image, I expect that image to be used on the careers profile too. Turns out it was using Gravatar, (which it only mentioned on the edit page, not on the creation page) so I've changed my email address from jobs@... to one that has a gravatar image.
9
  • I get Page Not Found for the link to your profile. Aug 5, 2013 at 11:51
  • @ShaWizDowArd Hmm, the URL must be different for other people. I will try to find myself through the employer's interface. Aug 5, 2013 at 12:07
  • 1
    Well, no top answers and there is profile image. While I believe you, better post screenshots to make it clear what the problem is. :) Aug 5, 2013 at 12:29
  • Regarding the third point, non gravatar support is planned. Aug 5, 2013 at 12:53
  • @ShaWizDowArd While investigating your first comment, I discovered my profile was not public by default, and changed it to be so. Alas, this caused the bugs to no longer be visible! While investigating your second comment, I saw that after making it public, it no longer contained the 'Top Answers' section that the private view had done. sigh Aug 5, 2013 at 12:59
  • That's weird, why having this only in private view?? Aug 5, 2013 at 13:10
  • I now see top answers but they're sorted in descending order of votes and the question having title starting with < shows up just fine. Case solved then? Aug 5, 2013 at 13:43
  • No, I sorted those manually (as having a public profile allows you to do). Really just ignore my public profile it has none of the bugs I saw before making it public! Aug 5, 2013 at 15:36
  • I see. If you can reproduce the bug in private profile it's probably still worthy of fixing though. :) Aug 5, 2013 at 17:58

0

You must log in to answer this question.

Browse other questions tagged .