I'm trying to log into chat (and now StackExchange as a whole after step 7), and I'm getting a mysterious error message:

No referer was present - this may be due to a browser setting

This appears to be the generic fallback for login failure, as the URL reads "/login/global-fallback". Meta has no information on this message. Specs:

Browser: Chrome v28.0.1500.95m
     OS: Windows 7 Professional x64

More specifically, I'm:

  1. Going to a chat window

  2. Pressing "log in" at the bottom, which takes me to the generic auto-login page (note: the top banner did not appear until I cleared all browser data; after I did so, it reads: "Please log in to any StackExchange site first, or log in via StackExchange.com"):

    enter image description here

  3. After some time, nothing happens. I then click "log in via StackExchange" (which works on mobile in desktop view for me), and this redirects me to this page:

    enter image description here

    There is nothing else on this page. It is simply this text. (This message is very ambiguous and should probably be changed to something more descriptive.)

  4. I go back to the first login page, and and proceed to visit the GlobalAuth test & help page. All five tests pass with flying colors. More specifically:

    • Cookies: OK
    • Messaging: OK
    • Storage: OK
    • Communication with StackAuth: OK
    • IFRAMEs: OK
    • Referrer: OK
    • JavaScript: OK
    • Time: OK
    • Storage: OK
  5. I clear my browser cache, and repeat steps 2-4, to no effect.

  6. I delete my StackExchange authentication data and repeat steps 2-4, to no effect.

  7. I delete all my authentication data for all websites and repeat steps 2-4. This actually has an effect:

After clearing all browser authentication data:

  1. I go back to the generic StackExchange login page. A banner appears indicating that I need to log in (which I think is silly). I dismiss it, and click "log in via StackExchange"
  2. This time, I am redirected to my Google authentication, which I happily enter, two-step verification and all
  3. Upon pressing submit, I am redirected to step 3 above.

Per a suggestion in the comments I have begun fiddling with my browser extensions in case one of them is stopping me from logging in. I have disabled everything, at which point I can log in. I then enabled the most likely suspects (HTTPS Everywhere, AdBlock, FlashBlock, Facebook Disconnect) to no effect; however, it appears that regardless of what the extensions actually are, if I have four or more of them enabled at once, I'm stopped from logging in. Four is the new magic number of evil.

Additionally, I have run several global logouts as part of the process of testing extensions. This appears to have no effect.

At this point, I don't know what to do. I've cleared the browser cache and all authentication data. The last thing I could do is to uninstall my browser and try again, but I don't really want to do that.

Also, I'm posting this from another computer, since I can't log into StackExchange any more on mine.

What should I do? Get a new computer? Reformat? ;]

  • I got the exact same error on Firefox on my old computer. I worked around it by logging in on safe mode. Commented Aug 5, 2013 at 17:42
  • 1
    @BoltClock Good point. I can log in under incognito, but I'd rather not browse in incognito all the time.
    – user206222
    Commented Aug 5, 2013 at 17:45
  • If you're surfing in incognito and it works, do you have any extensions/addons that interfere with requests as they happen?
    – Steven V
    Commented Aug 5, 2013 at 17:46
  • @Steven I have none that should interfere, or cause it to suddenly break for no reason (have not installed new extension in months), but I'll disable all of them and get back in a minute. Edit: Apparently it could have been an extension? I'm going to narrow down which one it was.
    – user206222
    Commented Aug 5, 2013 at 17:47
  • @Steven It appears to not be a specific extension, in that if I have more than four extensions enabled, I can't log in to StackExchange. I've edited the post to reflect this attempt.
    – user206222
    Commented Aug 5, 2013 at 17:55
  • Having any four extensions cause this problem?
    – Steven V
    Commented Aug 5, 2013 at 18:04
  • @Steven Regardless of what they are, yes.
    – user206222
    Commented Aug 5, 2013 at 18:04
  • I have like 15 and it works fine. Can I ask you to log in, then do a global logout?
    – Cole Tobin
    Commented Aug 5, 2013 at 18:08
  • @Cole I have done so as a part of testing extensions; this has no impact.
    – user206222
    Commented Aug 5, 2013 at 18:09
  • Did you try turning it off and back on again?
    – Cole Tobin
    Commented Aug 5, 2013 at 18:10
  • @Cole Turning what off?
    – user206222
    Commented Aug 5, 2013 at 18:11
  • Hmm... HTTPS Everywhere could cause some interesting problems. There is a HTTPS Everywhere rule in place for Stack Exchange. But since Stack Exchange doesn't have full HTTPS support, the referrer could be attempting to go from HTTPS to HTTP, which isn't allowed per the spec. I know it's far fetched...
    – Steven V
    Commented Aug 5, 2013 at 18:13
  • @Steven I've tried specifically with just the HTTPSE extension, and I can still log in.
    – user206222
    Commented Aug 5, 2013 at 18:15
  • @BoltClock How did you resolve the issue? Have you been using private mode since?
    – user206222
    Commented Oct 7, 2013 at 2:47
  • @Emrakul: I never managed to resolve it permanently - as a workaround I would start Firefox in safe mode, log in while there, restart it normally and the session will persist. I never found a permanent solution before I upgraded my PC and started from scratch with a new browsing profile. Commented Oct 7, 2013 at 7:22

2 Answers 2


For me, this blog post had the solution. In the browser extension HTTPS Everywhere, unchecking Stack Exchange (partial) when on chat.stackexchange.com did the trick for me. I don't know if this is only an issue when you have HTTPS Everywhere and other extensions running, but I wanted to share my solution in case others can be helped by it.

  • I'm going to mark this as the best answer, since it's the most helpful, until another one comes along which more accurately explains what's going on and why. Thank you!
    – user206222
    Commented Mar 10, 2014 at 3:31

It appears this was caused by having more than four active extensions in Chrome. I have no idea why this would be the case, but after extensive testing, it was clear this was the problem.

It's an unusual problem. I believe it is fixed in the latest revision of Chrome, though I'm not about to spend a couple hours testing it, sorry.

Weird issue, weird solution.

  • Well, comments state the same error was found in firefox, meaning it couldn't be just a chrome issue. Commented Oct 7, 2013 at 2:35
  • @Richard Hmm. I'll ask BoltClock how they resolved the problem.
    – user206222
    Commented Oct 7, 2013 at 2:46

You must log in to answer this question.