I attempted to flag this question on Christianity.SE...

...as "off topic". Although the initial flag dialog loads correctly, every time I selected the "it doesn't belong here, or is a duplicate" option, the next pane would fail to load:

Request URL:https://christianity.stackexchange.com/flags/questions/18136/close/popup?_=1375739403107
Request Method:GET
Status Code:404 Not Found

The account had 46 reputation. I tested this on other sites, but found that it only occurred on Christianity.SE. This was my only account that has the for the flagging privilege but not enough for the comment privilege.

I have now earned the commenting privilege on Christianity and am no longer able to reproduce this error, confirming its cause.

  • 2
    Appears to also reproduce with the duplicate close reason, which also attempts to create a comment without the privilege.
    – animuson StaffMod
    Aug 27, 2013 at 17:59
  • 3
    Shouldn't this be a 412 Precondition Failed or 410 Conflict instead?
    – Cole Tobin
    Aug 27, 2013 at 20:01
  • 1
    @ColeJohnson It should be a 200 OK. ;)
    – Jeremy
    Aug 27, 2013 at 21:23
  • 2
    @JeremyBanks why not 418 I'm a teapot?
    – Cole Tobin
    Aug 27, 2013 at 21:26
  • 1
    Holy Unintended Consequence, Batman! Yeah, close shouldn't be blocked by inability to comment; the close should just go through without posting the comment. Sep 10, 2013 at 21:54

1 Answer 1


Jarrod fixed this - if a flag type requires commenting privileges (as off-topic flags do) and the user doesn't have them, that flag type will not come up.

This is currently live.

  • Fair enough, though it appears some people don't really like that solution. Sep 15, 2013 at 6:43
  • @ShaWizDowArd - I can see where they may be coming from. Doesn't mean this is a permanent situation.
    – Oded
    Sep 15, 2013 at 6:54
  • In my opinion it's not a big deal, 15-50 is quite an edge case but still, it feels like more a hack than real solution. Still, better than a 404 error. :) Sep 15, 2013 at 6:58
  • 1
    @ShaWizDowArd - not disagreeing with you...
    – Oded
    Sep 15, 2013 at 6:58
  • @Oded I got the same error just now when clicking "close" on a question that was deleted in the interim. Red box 404 with the X to close. Maybe it's the same error and maybe it's unrelated, but seems worth looking at again. I'd expect it to be pretty easy to reproduce.
    – user
    Nov 11, 2013 at 17:32
  • @MichaelKjörling - do you mind opening a new Meta bug with a repro?
    – Oded
    Nov 11, 2013 at 17:34
  • @Oded meta.stackexchange.com/q/207005/157730
    – user
    Nov 11, 2013 at 17:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .