37

So I've been experiencing this in the last few days: sometimes when someone replies to my comment, and I reply to the reply, then the "add/show 1 more comment" link appears immediately after I post my comment. However, when I click it, it disappears and nothing is shown.

I don't think it's that OP is posting two comments of which he deletes the second one, because this has happened to me several times, even when I was replying within 2-3 seconds.

I do, however, believe that this is more or less the same bug as this one, except that I don't have to reload the page in order the link to be gone, and I also seem to be getting the erroneous behavior only if I reply to a comment which is itself a reply to an earlier comment of mine.

Unfortunately, I wasn't careful enough to take a screenshot last time this happened, but here's what I am talking about for those who like visual demonstration better:

enter image description here

  • 4
    Yeah, noticed it on and off so it's most likely some race condition. – Shadow Wizard Aug 9 '13 at 22:50
  • @ShaWizDowArd This has been already fixed once, but apparently came back :P – H2CO3 Aug 9 '13 at 22:50
  • 15
    I considered upvoting this, but I didn't want to encourage the combination of the "Eeeeeek!", the freehand circle, and the unicorn. – Peter Olson Aug 9 '13 at 22:50
  • Yep it's not surprising, with the recent changes to comments they probably swiped away some bug fixes. – Shadow Wizard Aug 9 '13 at 22:51
  • 3
    @PeterOlson Those three have been included deliberately. I want to boost my Meta reputation. – H2CO3 Aug 9 '13 at 22:51
  • 1
    @H2CO3 that's "Eeek" at most though. "Eeeeeek" is when something is really broken e.g. you see unicorns instead of question. :-D – Shadow Wizard Aug 9 '13 at 22:52
  • 3
    I know they're deliberate. I just think you're trying too hard to boost your rep by using old jokes. (We don't accept fun around here any more). – Peter Olson Aug 9 '13 at 22:52
  • 2
    @Peter hey at least he's not oscillating! (new joke just for you ;)) – Shadow Wizard Aug 9 '13 at 22:53
  • @PeterOlson Also, there's the "don't use this, Meta is a serious place" tag, amirite? – H2CO3 Aug 9 '13 at 22:55
  • 1
    Not fixed yet, flagged to reopen. (i.e. remove status-completed) – Shadow Wizard Aug 20 '13 at 11:47
  • @ShaWizDowArd Yeah, thanks! – H2CO3 Aug 20 '13 at 12:09
  • 1
    Cheers, I also recorded myself reproducing it. – Shadow Wizard Aug 20 '13 at 12:23
  • 1
    @balpha we got eeekified recently! :( – Shadow Wizard Aug 27 '13 at 12:09
  • @ShaWizDowArd All those young'uns not knowing what an Eeeek post is. – balpha Aug 27 '13 at 12:14
  • @balpha I know, but was too lazy/unsure to edit it myself. – Shadow Wizard Aug 27 '13 at 12:15
9

I've got it. I'll update when this is ready.

Update: This is fixed. Maybe. For now.

Update 2: Localization is progressing, and the comments feature is on-deck, so I've been putting off spending any more time on comments until that's done. Putting this to so I won't forget about it.

Update 3: refactored comments is basically done, and I fixed a couple of related bugs earlier today and haven't been able to reproduce this (not a cop-out...I did actually try). If anyone notices this behavior again comment on this answer.

  • 2
    It seems to be back again... – bfavaretto Aug 15 '13 at 0:23
  • 2
    No cigar. See here, I was able to catch the bug and... reproduce it! – Shadow Wizard Aug 15 '13 at 11:35
  • 1
    @ShaWizDowArd: localization is progressing, and the comments feature is on-deck, so I've been putting off spending any more time on comments until that's done. I've put this to status-deferred so I won't forget about it. – Ben Collins Aug 20 '13 at 14:21
  • Fair enough. :) – Shadow Wizard Aug 20 '13 at 14:41
  • 9
    Localization is progressing me gusta! – brasofilo Aug 27 '13 at 12:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .