5

When I try lo ask a question on the stackoverflow.com, I don't see a toolbar on the edit area nor do I get to post my question. It doesn't give me an error, but it simply cycles back to the same page.

Also, when I try to edit the user profile, I get the following error:

Oops! There was a problem updating your profile:
unusual error updating your profile -- please try again!

What else do I need to do to be able to post question on this site?

26
  • Do you happen to have javascript disabled? Are you getting any javascript/network errors? What browser and OS are you using?
    – Oded
    Commented Aug 11, 2013 at 13:59
  • Can you access cdn.sstatic.net/js/stub.js?
    – Arjan
    Commented Aug 11, 2013 at 14:00
  • Arjan: no I can't browse i get an error like "Oops! Google Chrome could not find cdn.sstatic.net Did you mean: sstatic.­net"
    – Kiran
    Commented Aug 11, 2013 at 14:02
  • Oded: not really, I am able to post on the meta.stackoverflow.com so I think the brower should not be an issue here. BTW I just registered today, is there a limit on how long I have to wait before I can post?
    – Kiran
    Commented Aug 11, 2013 at 14:06
  • @Kiran - No time limits, but if you can't find cdn.sstatic.net there may very well be a network problem on your end (possibly a proxy that is filtering out https).
    – Oded
    Commented Aug 11, 2013 at 14:39
  • @Oded, HTTPS is (temporarily) not used anymore, unless one explicitly wants to, right?
    – Arjan
    Commented Aug 11, 2013 at 14:47
  • Meta does not use the CDN for JavaScript, which is apparently why you don't have problems here. And yes, the browser might matter: Can't ask a question when IE Tracking Protection is enabled. (See also Replying in comments to ensure people get notified.)
    – Arjan
    Commented Aug 11, 2013 at 14:49
  • @Arjan - Wasn't sure about that. But regardless if the browser can't access the CDN, the OP will have problems
    – Oded
    Commented Aug 11, 2013 at 14:53
  • True, @Oded. Do you know if the list of things that can help the support people at the CDN to debug issues is still up-to-date?
    – Arjan
    Commented Aug 11, 2013 at 14:57
  • 1
    @Arjan - step 5 is most certainly out of date, we are no longer using netdna, AFAIK we are now using CloudFlare. Most other steps are pretty correct (except for the actual hosts).
    – Oded
    Commented Aug 11, 2013 at 15:03
  • @Arjan: I can reach sstatic.net/js/stub.js but not cdn.sstatic.net/js/stub.js BTW step 5 says "You are hitting the NetDNA London Datacenter" not sure if its still relevant.
    – Kiran
    Commented Aug 11, 2013 at 16:19
  • Without the "cdn" part, you're going to the Stack Exchange servers directly (198.252.206.16), not to the CloudFare CDN. That's all I know; maybe @Oded (being a SE employee) knows more. Still, he'll want to know: what OS? Which browser? Which provider? Did you try another browser and maybe another device in the same network? Are you on mobile? Anything else that might be special? Does London make sense?
    – Arjan
    Commented Aug 11, 2013 at 16:31
  • And @Oded, do you feel it makes sense that sstatic.net.cdn.cloudflare.net/js/stub.js gives me "Error 1001 DNS resolution error"? (Might very well be normal, but given the output of dig cdn.sstatic.net that includes cdn.sstatic.net. 2 IN CNAME sstatic.net.cdn.cloudflare.net., I figured that name might work too.)
    – Arjan
    Commented Aug 11, 2013 at 16:34
  • Are you using IPv6? (The error in my last comment shows I'm using IPv6 to access that error page; and so does curl -vi "http://cdn.sstatic.net/js/stub.js" However, forcing IPv4 for the long domain gets me the same error page; curl --ipv4 -v "http://sstatic.net.cdn.cloudflare.net/js/stub.js")
    – Arjan
    Commented Aug 11, 2013 at 16:37
  • @Arjan - I don't really know... Something for someone else in the team
    – Oded
    Commented Aug 11, 2013 at 16:56

0

Browse other questions tagged .