11

In the official announcement of the Android app, it says Android 4.1 or higher is required. However, the Google Play Store page argues that 1.6 is the required Android version. Why do these two pages argue with each other, and which one is lying?

Screen shot:

Stack Exchange app at Google Play Store

6
  • 3
    I get 404 for the link to Google Play Store, can you post screenshot in case it's a private page and not wrong link? Aug 27, 2013 at 6:44
  • 2
    @Sha: If you're not a member of the G+ Community, you won't be able to see the app in the Play Store. (I've added a screen shot.)
    – ale
    Aug 27, 2013 at 12:47
  • 1
    @ShaWizDowArd It's a valid page, you just have to be apart of the alpha. i.imgur.com/WzpqmZG.png is a screenshot of the entire page.
    – Steven V
    Aug 27, 2013 at 12:50
  • @ShadowWizardIsVaccinatedV3 Heh, just came across this post from my old account. It's now 404-ing again, because it was taken down more than a year ago... Oct 19, 2021 at 1:03
  • Yeah, now this question is perfect fit for the "No longer reproducible" close reason. Changes in the system (app abandoned) turns this to something not really relevant. Oct 19, 2021 at 6:58
  • Does this answer your question? How can I report bugs with or request features for the Stack Exchange mobile apps?
    – Rob
    Oct 19, 2021 at 7:22

1 Answer 1

18

The Google Play page is lying. Looks like we're not the first to have that issue.

The required version is Ice Cream Sandwich, i.e. 4.0., and our APK's minSdkVersion field correctly specifies API level 14. That's also what the Google Play admin page says as well. So – no idea why the public app page says something different.

We don't actively test on ICS devices, but we want it to work there, so when we see version-specific crashes on 4.0 devices (usually because of View.setBackground(Drawable)), we'll fix those.

Note that this is just the current state of affairs; we have postponed the decision whether it's worth to eventually support devices down to Gingerbread until later.

So at this point:

  • The recommended Android version is 4.1+, because that's what we're developing on.
  • The minimum Android version is 4.0.
  • Anything below that is pretty much guaranteed to break, even if you manage to install the app.
1
  • I'm going to try it on ICS. I don't have an Android 1.6 device to test it on, though, so if one who is kind enough to test it there does so and reports the results, that would be nice.
    – user215114
    Aug 27, 2013 at 16:53