3

This question already has an answer here:

For a few days now, when I add a comment, SO will (sometimes) show my comment and indicate that there are one or more new comments, and on showing the new comments, it is just my comment that is shown. Just now, it told me there were 6 new comments; there weren't — there was just mine.

SO didn't used to get confused about that. Please fix it so it is unconfused once more.


Specific context: I have designed a sorting algorithm for a linked list.

I set out to reproduce it — the site recognized that it was under scrutiny and refused to cooperate.

The problem seems to be intermittent, or to depend on the sequence of actions you undertake. But I've noticed it on and off for most of this week. I don't think it depends on having a lot of comments; I've seen it with a couple of comments in the question. I'm not sure whether it is restricted to comments to the question; I think it can occur with comments to an answer too.

I've seen it with both Firefox (23.0.1) and Chrome (29.0.1547.57) on Mac OS X 10.8.4.

Documentary Evidence

Question: segfault during write to the realloc'd area

When the question is first loaded there are a number of hidden comments (now 10, was 9 when I started):

Showing 10 comments initially hiddent

When I added a comment, it said there were 8 more to show:

8 more comments

When I tried to show the '8 more comments', they weren't there:

not 8 more comments

After reloading and redisplaying, the comments available were:

look at them all

Strictly speaking, the images were generated in the order 2nd ('8 more'), 3rd ('not 8 more'), 1st ('10 more'), and 4th ('look at them all'). I've not tried adding yet another comment. But this bug is still active a week or more after I reported it, and a month or more after it was first reported.

marked as duplicate by Mat, Frédéric Hamidi, Jonathan Leffler, psubsee2003, Lance Roberts Aug 29 '13 at 18:12

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Yes, this is that same bug...maybe it has been going on longer than I realized. – Jonathan Leffler Aug 29 '13 at 15:45
  • It is still going on a month later, and it is still irritating. – Jonathan Leffler Sep 29 '13 at 3:43

Browse other questions tagged .