4

This question already has an answer here:

I am having a problem downloading the application on the play store, clicking the link just gets me to an "Item Not Found" page. I have a Samsung Galaxy S3 in case it matters.

Steps to reproduce

  • Open the community page with Google+ app on my Android device
  • Click the link
  • Click the "Join Testing" (or whatever that button says)
  • Click the download link
  • Select to open in Google Play
  • "Item not found" error

marked as duplicate by hims056, Martijn Pieters, Aziz Shaikh, Rory, asheeshr Sep 8 '13 at 5:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    @gnat: That is not a duplicate. I had initially put my answer directly on that question (it is now deleted), but I created this question because I realized that it wasn't the same problem. Also, that question has "Status-Completed", so if it was the same issue I wouldn't have had the problem this morning. right? – musefan Sep 5 '13 at 9:59
  • I am having the same issue. It seems that it takes some time before play store knows that you are in the testing group – Zapnologica Aug 18 '15 at 11:49
  • Where is this duplicate question? – Zapnologica Aug 18 '15 at 11:50
2

UPDATE: The problem has now been fixed, so the following work around is no longer applicable.


I managed to get around it as follows:

  • Open the community page with Google+ app on my Android device
  • Click the link
  • Click the "Join Testing" (or whatever that button says)
  • Click the download link
  • Select to open in Chrome (web browser)
  • Click the "Install" button
  • Wait for package to download
  • "Package not a valid format" error (yet another problem)
  • Click "OK" (or something)
  • It then automatically opens the correct Play Store page, where you can click Install and it will download and install correctly

Not the answer you're looking for? Browse other questions tagged .