What reputation amount is needed in order to post a comment in the Android application? When I try to comment on any answer/comment I get the following message:

This user has not earned the privileges needed for creation of comment on the API.

Is the amount required not the same as it shows in the Privileges section in meta or is it 50 like the main SO site? I have 50+ on the main site but not yet 50 on meta and have tried commenting in both places on the app with the same result.

Also, although the message clearly states why I cannot comment, a suggestion would be to include the reputation amount needed to comment.

I'm on version 0.1.30

  • 2
    Have you looked at the docs that outline the limits on write-access to the API?
    – blahdiblah
    Sep 11 '13 at 20:55
  • @blahdiblah the Android app uses a different API Sep 11 '13 at 21:10
  • I just read through the write access doc you provided. I'm not understanding what I need to do to register to post? Could you explain more please?
    – Brian
    Sep 11 '13 at 21:21
  • 5
    @Manishearth Incorrect, we're dog-fooding here and using our own API, which is what is causing this issue. We haven't fully fleshed out the privileges requirements side of things so I'm just going to let this question stay open until we do. Sep 11 '13 at 21:21
  • @KasraRahjerdi thanks for the update. Any idea on when the privilege requirements might get worked out or should I just keep trying as updates roll out?
    – Brian
    Sep 11 '13 at 21:24
  • 1
    @Brian If you're only concerned with commenting the link posted is the correct answer, you need 50 reputation to comment on something using the API, I'm not going to file that as an answer to this though since it doesn't really answer your request of returning that in the error message. Sep 11 '13 at 21:25
  • @KasraRahjerdi Hmm, interesting. I recall George Edison/Nathan Osman saying something about the different "secret" API that he discovered from the app. ICBW. Oh well. Sep 11 '13 at 21:27
  • @KasraRahjerdi thank you.
    – Brian
    Sep 11 '13 at 21:29
  • 1
    @Manishearth That could be the undocumented features we're adding to it, for a discussion of those see here - meta.stackexchange.com/a/195557/229741 Sep 11 '13 at 21:31
  • @Manishearth I think it's just that the new version 2.2 of the API is currently "secret", not that it's a distinct API.
    – Jeremy
    Sep 12 '13 at 0:39
  • @KasraRahjerdi Now that I have 50+ rep, I tried to comment but still get the same message. Am I misunderstanding exactly what's required?
    – Brian
    Sep 12 '13 at 0:57
  • @Brian I believe it should be working for you now, if you're using it on a site where you have 50 reputation. I would guess you're currently dealing with cached permissions; how long has it been since you passed 50 rep?
    – Jeremy
    Sep 12 '13 at 15:45
  • @JeremyonVacation I passed 50 on meta yesterday. I also updated to v0.1.31 today. I thought about it possibly holding on to permissions so I tried logging out as well as rebooting my phone. Just tried to post this comment from the app too but wasn't able to.
    – Brian
    Sep 13 '13 at 12:47
  • @KasraRahjerdi Just updated to v0.1.32 and am able to comment now. I can't test if the error message changed to include a more descriptive explanation though. I'll leave this open for now.
    – Brian
    Sep 14 '13 at 0:56

You must log in to answer this question.

Browse other questions tagged .