1

Take an example on this question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

  • By redirection I mean: Click this Oded's comment's link which redirects us there. But my comment's link on the same question doesn't redirect there. – hims056 Sep 12 '13 at 11:34
  • No repro here. Windows 7, IE 9, FF 23.0.1, Opera (Next) and Chrome 29.0.1547.66 m – Oded Sep 12 '13 at 11:39
  • 1
    I was able to reproduce this in Chrome/Firefox for a Mac. I can get directly to Oded's comment but not @hims056 – Taryn Sep 12 '13 at 11:46
  • 1
    @Oded Repro here on that exact Chrome build and Win7. – Billy Mailman Sep 12 '13 at 11:46
  • 2
    Reproduced with Firefox 23.0.1 on Windows 7. Browser does not scroll down to the actual comment. – Johannes Kuhn Sep 12 '13 at 11:47
  • 2
    Looks like you edited the comment - the link is this which is different from what you posted – Oded Sep 12 '13 at 11:53
  • @Oded - How did you get that link? Because clicking on timestamp of the comment gives me the link I have posted. – hims056 Sep 12 '13 at 11:55
  • But once I open the comments, it will scroll down if I hit Enter in the adress bar. – Johannes Kuhn Sep 12 '13 at 11:55
  • I went to the comment, right clicked on the timestamp and copied the URL. – Oded Sep 12 '13 at 12:22
  • @Oded - But it gives me the one I have posted. – hims056 Sep 12 '13 at 12:24
  • Strange. This is after reloading the page? – Oded Sep 12 '13 at 12:31
  • 1
    Even in incognito mode I see the timestamps link to URLs like Oded saw, so: with the underscore and question id. Also after clicking "show more comments" on long comment threads... (Chrome on a Mac.) Do you have some old user script installed to create the links, from times where the timestamps were not linked by Stack Exchange yet? – Arjan Sep 12 '13 at 12:42
  • 1
    I would go with @Arjan and blame user script (maybe "reply-to" script?) and I've tried with "fresh" comment and the AJAX-generated link is just fine. :) – Shadow The Princess Wizard Sep 12 '13 at 13:04
  • 4
    This question appears to be off-topic because the given bug occurs due to external UserScript which we don't support. – hims056 Sep 13 '13 at 3:53
  • 1
    Maybe worth posting official warning then or ask the script writer to fix it? :) – Shadow The Princess Wizard Sep 13 '13 at 18:04