1

Stack Overflow's live refresh gets you instant notifications without having to do a F5 every time. But this behaviour doesn't seem to work when the browser uses some proxy connection to connect to the internet.

Foe example, at home, I connect to the internet directly without any proxy settings configured for the browser and the SO site refreshes normally. But when I use it from my workplace, I need to configure a particular proxy in the browser to be able to access the internet. In this scenario, the live refresh features of SO don't seem to work. I don't get any notifications as such. Only when I refresh the page by pressing F5 or reloading the page by clicking in the question link again, do the notifications show up.

Why is it so? Is there a no live refresh feature in place which blocks connections from a proxy IP? I'm really not sure how the live refresh feature works, but I really cannot understand why using a proxy setting in the browser would not refresh the site on its own. Can anybody please throw some light on this issue?

Edit: This is the URL to the result I got on opening the Web sockets test site. The result was It might work for you. But unfortunately its still not working for me. Any ideas?!

  • 6
    Live refresh depends on web sockets working. If they don't work (as would likely be the case with a misbehaving proxy), it will not work. – Oded Oct 12 '13 at 13:05
  • Can you please explain what exactly is a misbehaving proxy? Because, as far as I know, the proxy I use at my workplace has no restrictions and we can freely access the internet without any other glitches. The auto-refresh of a site like Cricinfo works just fine. – SudoRahul Oct 12 '13 at 13:08
  • In this context, a proxy that blocks web sockets. – Oded Oct 12 '13 at 13:09
  • 3
    What does websocketstest.com give you? If all that reports fine, then maybe Stack Exchange can improve something. – Arjan Oct 12 '13 at 13:09
  • @Arjan - That's a great site(I never knew such a site even existed), but unfortunately I'm at my home right now, not at my workplace. Probably I can share the results when I go back to my office after the weekend?! – SudoRahul Oct 12 '13 at 13:12
  • See also "What else do I need" in Which browsers are officially supported? And what else do I need? – Arjan Oct 12 '13 at 13:14
  • @Arjan - I updated my question with the results from the site you suggested. Any ideas?! – SudoRahul Oct 15 '13 at 4:02
  • @Oded - I updated my question with the results from the websocketstest site and the result was that websockets are supported. Any ideas as to why its still not working?! – SudoRahul Oct 15 '13 at 4:03
  • There's a difference between supported and might be supported – random Oct 15 '13 at 4:04
  • @random - It says websockets are supported. Please check the result URL. The message I got after the test got completed was it might work for you. I don't know what that exactly meant. – SudoRahul Oct 15 '13 at 4:06
  • 2
    Our websockets, like most websockets, work over port 80 which is blocked by your proxy as stated in your results. – Kasra Rahjerdi Oct 15 '13 at 4:07
  • @KasraRahjerdi - And exactly that doesn't work in my case. Anyways thanks for pointing that out to me. Just the final question, is there any work around for this already in place?! Or do I have to put up with this for eternity? – SudoRahul Oct 15 '13 at 4:12
  • I'm assuming when we switch over to HTTPS websockets will work on both 80 and 443, but I don't know when that is. – Kasra Rahjerdi Oct 15 '13 at 4:20
  • And obviously: send those results to your system administrator. It might just be a configuration error? – Arjan Oct 15 '13 at 8:12
  • @KasraRahjerdi - The live refresh seems to be working for me since this morning. Has the switch you were talking about completed?! In any way, this seems to be great as I no longer have to keep refreshing the page manually. – SudoRahul Oct 28 '13 at 4:21

You must log in to answer this question.

Browse other questions tagged .