5

I was browsing through the SproutSocial company page. It's beautifully designed, but when I got to the gallery part and clicked on a different photo, it took a good 1-2 seconds for the other image to load, and there wasn't an indicator that something was happening.

Could we add a loading indicator and/or compress the images?

  • No repo here; what browser are you using? On Chrome 30.0.1599.101 on Mac OS X 10.8.5 the gallery images load nice and fast. All images are hosted on the i.stack.imgur.com CDN, which hosts all images across the Stack Exchange sites. – Martijn Pieters Oct 16 '13 at 13:35
  • Is this a recurring problem for you, intermittent or just a one time issue? – Nick Larsen Oct 16 '13 at 17:04
  • @MartijnPieters I am using Chrome 30.0.1599.69 on Mac OS X 10.8.5. From the Millenium hotel, where ping and bandwidth is generally good, I can get consistent results. See the following screenshots: imgur.com/a/st77R. The first one shows the case where only one of the images downloaded slowly. The second one shows where x images out of y loaded slowly. – Arie Litovsky Oct 17 '13 at 12:19
  • @NickLarsen reproduced here (Israel), one full second for 600Kb image - preloading all images should solve this, is it feasible? – Shadow9 Oct 23 '13 at 18:06
1

I have added preloading to the gallery images. This won't solve the issue of some of the images failing to load, but it should speed up general case. I cannot really reproduce it here, so let me know if the experience is still bad and I will add some kind of loading animation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .