2

Today when I was reviewing I came upon this review audit. Review Passes all well, but when you click on add / show 1 more comment you are thrown with error as shown in below screen shot...

enter image description here

Which was somewhat expected since the post has now been deleted.. But, why is the link still enabled..

I believe there was something like comments disabled on review/locked/deleted post or something like that *Cant remember exact message.

This is a case of deleted post, so why is this link still enabled..

EDIT

As per below comment.. it seems >10K users cannot reproduce the issue... You guys can still reproduce by logging off your current account and then clicking the link as anonymous user.

NOTE:- The error message is not an issue here(thats correct).. IMO the add comment link itself has to be disabled since the post is deleted

  • Are you sure it is not your internet connection. This happens to me only when I loose network – Walker Oct 29 '13 at 10:58
  • 2
    @PreciousTijesunimi Yes, I am sure, I have no connection issue... You can check it for yourself.. try clicking on add comment link through link I provided above ... This bug is reproducible... Actually, the error message is not an issue here(thats correct).. IMO the add comment link itself has to be disabled since the post is deleted – CRUSADER Oct 29 '13 at 11:02
  • 2
    On deleted posts (either yours or when you have 10K rep) you see only "show X more comments" and clicking it load all comments then showing "comments disabled on deleted / locked posts" instead of the "add comment" link. In your case it's not your post and you have less than 10K, so the server side validation was triggered. The audit should indeed either fetch all comments in advance, or hide the link. Having 10K, I can see the additional comment, here it is: i.stack.imgur.com/8r4LJ.png – Shadow Wizard Oct 29 '13 at 11:10

You must log in to answer this question.

Browse other questions tagged .