This question already has an answer here:

When I wished to show example data, I used the code block syntax (4 spaces indentation after an empty line), but the data was rendered like a programming language. Can I prevent the syntax highlighting?

2013-01-01 1.30 1.35 1236
2013-01-02 1.20 1.37 1237

...or is there another syntax in markdown?


EDIT:

I the above example, the problem seems not to occur? The original problem, and data

James Bond
01/01/12 200010
03/30/12 -40000
04/30/12 -40000
05/30/12 -40000
06/30/12 -40000
07/30/12 -40000

was here: C++ Bank Project; How do I read string from file convert to float and sum all

marked as duplicate by hims056, Martijn Pieters, Hugo Dozois, Undo, ben is uǝq backwards Oct 30 '13 at 21:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @hims056: this questions deals with forcing highlighting and doing it right – Wolf Oct 30 '13 at 12:13
  • @Quantas 94 Heavy: As I already mentioned, this is a very vague question with no formal answer. – Wolf Oct 30 '13 at 12:16
  • @WolfP. - The first language code given there is "none" – hims056 Oct 30 '13 at 12:20
  • @hims056: Yes. But it's 5 questions and the 3rd of them matches only partially. Also, I'm still undecided which solution is better in the case of non-code: code blocks or the pre tag which is basic markdown (in the latter case the text would be "portable")... – Wolf Oct 30 '13 at 13:26
up vote 8 down vote accepted

You can use the lang-none syntax highlighting comment:

<!-- language: lang-none -->

    Your data...
  • This seemed the first choice to me, but for plain text I considered it as an "overkill". BTW: is there a sandbox for testing safely? – Wolf Oct 30 '13 at 10:32
  • @Wolf, yes, there is. – Frédéric Hamidi Oct 30 '13 at 10:37
  • @WolfP. There's a formatting sandbox on Meta, but if that doesn't cut it you'll just have to abuse the live preview on SO. – michaelb958 Oct 30 '13 at 10:37
  • @michaelb958: Thanks. I saw only now that syntax highlighting is also active in the preview, but delayed. Knowing that, I feel much better :) – Wolf Oct 30 '13 at 14:53
  • 1
    @WolfP. Yeah, you have to stop typing for five (5) seconds before syntax highlighting happens in the preview. – michaelb958 Oct 30 '13 at 20:35

Just use <pre> tags:

<pre>
2013-01-01 1.30 1.35 1236
2013-01-02 1.20 1.37 1237
</pre>

It will display the text as is:

2013-01-01 1.30 1.35 1236
2013-01-02 1.20 1.37 1237

Here on meta there's no code prettify so it's not relevant.

You could use the block quote, which is the character > then your text, like this:

2013-01-01 1.30 1.35 1236
2013-01-02 1.20 1.37 1237

The reason why your data was colour coded was due to the language you tagged your question with.

Edit: Disregard this - it's an option but Frédéric's is better and Shadow's example means a more appropriate font is used.

  • In tried this, but it did not what I wanted. – Wolf Oct 30 '13 at 10:30

Not the answer you're looking for? Browse other questions tagged .