6

I've noticed in the last few days that if you go to someones Profile Page that there reputation shows top 3% this week or whatever the percent is. However, sometimes that % isn't for the week. If you reload the page for that user then it says the correct time-period of month, quarter, year, all-time, whatever.

I tested it with my own profile and others like martijn-pieters. I didn't have many points for the week whatsoever, and then it changed back to quarter like it should have (or year for Martijn) when the page is reloaded.

Has anyone else noticed this? Is this a bug with SO?

As requested here are some screen shots. This doesn't happen with every user or every time. I noticed this last time that the Reputation was calculating when it occurred.

If it matters I was using Google Chrome.

Shows Week Reputation on first load

Shows Month Reputation on reload

You can also see it should be month not week based on league rankings.

Week Rank

[abarnert]
abarnert
3 32 77
member for: 2 years, 2 months
**#747 week rank**
-716 change
65,016 total reputation
155 week reputation

Month Rank

[abarnert]
abarnert
3 32 77
member for: 2 years, 2 months
**#19 month rank**
+46 change
65,016 total reputation
6,408 month reputation

Here it is for me and I'm definitely not in the top 3% for the week.

Harrison
2 16 
member for: 7 months link
#7296 week rank 
-5786 change 
906 total reputation 
25 week reputation

My Profile Page showing week instead of quarter

  • Hmm... I just viewed the two profiles you linked, and I saw year and quarter. – Andrew Barber Oct 30 '13 at 14:24
  • @AndrewBarber Wierd. Once I load the page again it says it right, because it is in cache, but I know you wouldn't have had my profile in cache, so I don't get it. – Harrison Oct 30 '13 at 14:26
  • 1
    @Harrison Oh, umm... yes, not in cache, because I'm not stalking you ;) – Andrew Barber Oct 30 '13 at 14:27
  • 1
    @Dukeling. I have updated adding screenshots. It took about 7 or 8 users to find one that showed the issue, but there you go. – Harrison Oct 30 '13 at 14:51
  • 2
    Probably my fault. I'll take a look. – Sklivvz Oct 30 '13 at 15:09
  • @Sklivvz It's always Sklivvz. – Andrew Barber Oct 30 '13 at 15:15
  • According to jsfiddle.net/AYPpF/82/embedded/result it was balpha's fault. – Travis J Oct 30 '13 at 16:50
  • 1
    @AndrewBarber wrong it's always caching, and I'm almost certain it is caching this time. Checking with Marc Gravell... :-) – Sklivvz Oct 30 '13 at 17:15
  • @Sklivvz Did you change something? Now it's acting a little different. Now it will sometimes not show the top % at all instead of showing it for week and then at reload shows it properly. – Harrison Oct 31 '13 at 2:19
  • There was a caching issue due to some change, now the cache has been invalidated. It's a long running query. – Sklivvz Oct 31 '13 at 2:23

You must log in to answer this question.

Browse other questions tagged .