I am experiencing a strange behavior: In reopen review, when I explore the "revision" tab, I am stuck in "side-by-side markdown" format, and cannot change to any other format (i.e., not to "side-by-side" and not to "inline".

So I'm stuck in this view:

screen shot

Whenever I click on "inline" or "side-by-side markdown" I simply get three dots at the right hand of the screens and nothing happens.

Is this a known issue? Is there a fix for it?

I'm using Chrome on Windows 7.

Looking at the network traffic (dev tools), gives me this:

I don't really know what to make out of it...

  • Press shift+F5 and try again. – user206222 Nov 4 '13 at 8:04
  • Do you perhaps have an unstable / very slow internet connection? – Bernhard Barker Nov 4 '13 at 8:36
  • If you look at the revision history of the audit post the latest revision was just whitespace, which might not show up in the diff. It also means that the side-by-side diff might be considered incorrect. A similar thing happened to this one... it looks like "old" or "minor" diffs are being put through the queue, or that combined diffs are being added up to make a substantial one and therefore put it in. – ben is uǝq backwards Nov 4 '13 at 8:38
  • Might be a plugin/user-script/extension going wild. Disable all of those and see if this helps. – Shadow Wizard Wearing Mask Nov 4 '13 at 8:38
  • @Dukeling this behavior is going on for several days now, with multiple net connections. So I guess it is not a slow connection issue. – Shai Nov 4 '13 at 9:14
  • @Emrakul I tired that - did not help. – Shai Nov 4 '13 at 9:16
  • @ShaWizDowArd I disabled extensions (all of them) stepped out of "developer mode" and still no change. – Shai Nov 4 '13 at 9:20
  • Let's try to debug then - open the dev tools and go to the Network tab. When you click "side by side markdown" for the first time, you see request sent to the server? If so, what is the response sent from server to browser? – Shadow Wizard Wearing Mask Nov 4 '13 at 9:27
  • @ShaWizDowArd thank you for the help. posted a screen shot, I hope I got the right view and info. – Shai Nov 4 '13 at 9:36
  • Wow, 404! That's weird. – Shadow Wizard Wearing Mask Nov 4 '13 at 9:38
  • OK, right click that item in red and choose "Copy link address". Paste the full URL here and we'll finally see what happened. Example for valid URL: stackoverflow.com/revisions/19672714/… – Shadow Wizard Wearing Mask Nov 4 '13 at 9:39
  • @ShaWizDowArd url: stackoverflow.com/revisions/19741547/isions/… (sorry it took me so long). – Shai Nov 4 '13 at 11:11
  • 2
    looking, fixing... – m0sa Nov 6 '13 at 13:18
  • 1
    @ShaWizDowArd tnx for having my back ;) – m0sa Nov 6 '13 at 22:02
  • 1
    @m0sa you're welcome but turns out it didn't help - it's not fixed yet. :( – Shadow Wizard Wearing Mask Nov 6 '13 at 22:52

Reproduced in Chrome and IE10 and Found the bug, but only a dev can fix this.

In ordinary revisions page, the HTML structure is: (example)

So when clicking action link, it will go upwards and look for parent element with ID starting with "rev" and take the rest as the desired revision GUID. Works well!

Inside review page (probably any review, not just reopen) it's different: (example)

There is no GUID, it find the "revisions" and think "isions" is the GUID, hence that weird URL: https://stackoverflow.com/revisions/19741547/isions/diff?difftype=SideBySideHtml&_=1383563432814

| improve this answer | |
  • Thank you for this debugging effort! – Shai Nov 4 '13 at 12:27
  • Thank you for following up on this and directing @m0sa at the right direction! – Shai Nov 7 '13 at 5:58
  • @Shai cheers, but you really should accept m0sa's answer, he's the one who actually fixed it. :) – Shadow Wizard Wearing Mask Nov 7 '13 at 7:40
  • From the little experience I have with debugging, making the diagnosis is sometimes the most difficult part... – Shai Nov 7 '13 at 7:47

Fix will be rolling out shortly. There was a problem in the revisions.js script which did not go down the designated path in the reopen and close review queue task views.


Turns out there were actually issues with the revision switcher in the reopen queue both while reviewing (which was fixed in .1133) and in the review results (fixed in .1134)

Watch for revision numbers 2013.7.11.1612 on meta and 2013.6.11.1134 on the sites.

| improve this answer | |
  • Hope "shortly" won't turn to 6-8 weeks! ;) – Shadow Wizard Wearing Mask Nov 6 '13 at 20:16
  • Rolling out as we speak... – m0sa Nov 6 '13 at 22:01
  • Just curious, who decided when there is a deploy? Sometimes I see two in couple of hours, sometimes only once a day. (weekends mostly) – Shadow Wizard Wearing Mask Nov 6 '13 at 22:04
  • OK, that's weird. Revision is 2013.11.6.1133 but it's yet fixed, neither is that other bug - what happened? – Shadow Wizard Wearing Mask Nov 6 '13 at 22:51
  • 2013.11.7.1134 it is then... – m0sa Nov 7 '13 at 0:40
  • @m0sa working like charm! Thank you very much! – Shai Nov 7 '13 at 5:57
  • @m0sa any idea what happened to that other bug? Maybe he forgot to commit his fix or something? – Shadow Wizard Wearing Mask Nov 7 '13 at 7:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .