11

I was trying to look for an answer of mine earlier and did a search like this:

user:me SQLite RunInTransaction

The above found nothing. So I changed it to

user:me SQLite

Which found a bunch of things. I dug through the results and saw this snippet for one of my answers:

From my experience, wrapping as many database calls as possible into a transaction speeds things up quite a bit: using (var db = new SQLiteConnection(dbPath)) { db.RunInTransaction(() => { …

Notice that the snippet contains both "SQLite" and "RunInTransaction". In looking at the post itself I noticed "SQLite" was in the question title and in my answer as code. I also noticed that "RunInTransaction" is only in my answer in code.

I looked at meta and saw this post, which says I need to prefix any code with code:, so I tried:

user:me SQLite code:RunInTransaction
user:me code:SQLite code:RunInTransaction

None of the above returned any results.

I also found this post on meta which says I can search for code like this (without the code: prefix):

"COUNT(*) AS UpVotes"

So I tried:

SQLite RunInTransaction
"SQLite RunInTransaction"

The first did not return my answer. The second did not return any results.

So my question:

How do I properly search for my answer, that has both "SQLite" and "RunInTransaction" in the post?

4

Whole words only, that's the problem here. Not sure if it's a bug or by design.

For what it's worth, this query will return what you're after:

user:1822514 SQLite db.RunInTransaction
  • that's likely done for performance reasons. "contains" string comparisons can't be used in a search index very effectively. – Servy Nov 6 '13 at 19:04
  • 1
    At least that's better than "db.RunInTransaction(()" :) Seriously though I would think that "db.RunInTransaction" would be tokenized into two words. – chue x Nov 6 '13 at 19:06
  • @chuex Servy is probably right, as for two words, there's no space thus considered one word. – ShaWiz Nov 6 '13 at 19:07
  • 1
    I don't like the tokenization rules regarding the period, but that seems to be the issue. Thank you for your time. – chue x Nov 7 '13 at 16:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .