The close-vote reason for this question (10K+ link) looks like below:

Pekka messing up the commas

The comma should come after the little guy (웃   ). I don't know if Pekka would agree, but it would be nice to see this fixed.

Reproduced again (even weirder this time) on this question:

Problem appears on Stack Overflow - Google Chrome 31.0.1650.48 on Ubuntu 13.04.

  • Do you mean ASCII or Unicode? – Andrew Barber Nov 14 '13 at 15:18
  • @AndrewBarber: Unicode. – Amal Murali Nov 14 '13 at 15:20
  • Excellent! Sometimes I get mixed up, so I didn't edit it myself. – Andrew Barber Nov 14 '13 at 15:20
  • 2
    Oh, and maybe the little guy 웃 does not like having commas behind him... ;) – Andrew Barber Nov 14 '13 at 15:21
  • 3
    I was unable to reproduce this. The dude was getting along fine with the comma (or his duderness if you aren't into the whole brevity thing). – Travis J Nov 14 '13 at 15:24
  • What environment were you viewing the dude from? – Travis J Nov 14 '13 at 15:26
  • 3
    @AndrewBarber: ASCII is Unicode too.. Perhaps 'Non-ASCII'? – Martijn Pieters Nov 14 '13 at 15:28
  • @MartijnPieters Technically, you are absolutely correct! Though I think people know what is meant here. That said, I do love being technically correct, and being corrected when I'm not! :) – Andrew Barber Nov 14 '13 at 15:29
  • 3
    Oh, and RE @TravisJ; I'm also unable to reproduce it. I see the little dude just fine. – Andrew Barber Nov 14 '13 at 15:30
  • 1
    That looks as if your browser overrides the writing direction for that character. The character itself is Left_To_Right, but seems to be displayed Right_To_Left almost. – Martijn Pieters Nov 14 '13 at 15:30
  • 3
    @AndrewBarber: I wouldn't be a proper geek if I wasn't being pedantic about technical nuance. :-P – Martijn Pieters Nov 14 '13 at 15:31
  • @MartijnPieters Yeah! One thing that always confuses me about some programmers who aren't careful with their spoken/written language; You would think that being a programmer, they would know how important it is to use precisely the correct words. – Andrew Barber Nov 14 '13 at 15:33
  • Can't reproduce with Chrome. Please specify your browser and OS. – Shadow Wizard Nov 14 '13 at 15:39
  • @ShaWizDowArd: Updated the question with browser and OS. – Amal Murali Nov 14 '13 at 15:47
  • 1
    That guy is a part of Pekka's name, not of the other guy – John Dvorak Nov 14 '13 at 16:52

This is not related to some CSS or font size; it's an issue with a font on your Ubuntu.

I see all just fine:

Also, I see the additional whitespace where you typed (웃   ) in your question, which on your computer apparently was needed to fix the erroneous font, even in a regular paragraph?

If you figure out which font is used for those characters, try to disable it and see if the browser then uses another font that does a better job.

To determine which font is used, see How can I determine what font a browser is actually using to render some text? And beware that different browsers might use different fonts on the very same machine, like described there too.

(FileFormat.info claims that "U+C6C3 is not a valid unicode character". I don't know what that means.)

  • This works perfectly fine on Firefox. Here's a screenshot. Don't know why it isn't working on Chrome. – Amal Murali Dec 29 '13 at 15:20
  • I copied the text into a Rich Text Editor as you suggested. For Chrome, it shows Trebuchet MS, and for Firefox, it shows Arial. That's probably the issue. Let me see if I can disable this font. – Amal Murali Dec 29 '13 at 15:52
  • I'm afraid you didn't select the 웃 character then? I doubt your Trebuchet and Arial actually include that character, @Amal! – Arjan Dec 29 '13 at 15:55
  • Also, @Amal, the copy-into-editor trick didn't work for me for Firefox. And your first screenshot already shows Firefox is using NanumGothicBold. – Arjan Dec 29 '13 at 15:58
  • As an aside, @Amal, if you happen to use Hindi, and if the Hindi script also can combine letters into words like Arabic does, then you might want to look at the screenshots of the problem with Arabic I once had. Just for future reference: if you ever see the combining of letters fail, you know it's related to font types that browsers prefer, and some bad font on your system. (To me, not paying attention at the time, both screenshots looked the same.) – Arjan Dec 29 '13 at 16:06
  • I uninstalled all non-English fonts and that seems to have fixed the issue, but I can't still get it to work in Incognito. Not sure what's the issue, @Arjan. – Amal Murali Dec 29 '13 at 18:35
  • On Windows I'd say: reboot, @Amal... (I don't know why incognito mode would use different fonts, unless a different CSS is loaded. Do you get the same font when copy/pasting in incognito mode?) – Arjan Dec 29 '13 at 18:37
  • And did you get a different font than Trebuchet when truly only selecting that funny character after pasting, @Amal? – Arjan Dec 29 '13 at 18:39
  • And, @Amal, see also fileformat.info/info/unicode/char/c6c3/fontsupport.htm and the link to "Local Font List tool" on that page. – Arjan Dec 29 '13 at 18:50
  • Okay. Reeboted the machine 5 times, re-installed the default font package. This is the latest condition: i.imgur.com/KFHcHVD.png (btw: thanks for trying to help. I really appreciate it :), @Arjan – Amal Murali Dec 29 '13 at 19:19
  • I'm afraid you're on your own there, @Amal. See also my comments about selecting only the funny character after pasting into a rich text editor. (I did not expect to see Trebuchet as a result.) And when all done, here's some more screenshots to compare... Success! – Arjan Dec 29 '13 at 20:03
  • 1
    Thanks for all the help, @Arjan. After browsing through many threads on Ask Ubuntu, Supe User (including the thread you just linked above :P), Google Groups etc. I was able to fix this. I re-installed Google Chrome from scratch, re-installed the system fonts and all available non-English font packages, with this command. SUCCESS!. – Amal Murali Dec 29 '13 at 20:10
  • Yeah, I have posted an answer, @Arjan :) – Amal Murali Dec 29 '13 at 21:17
  • What do you know, @Amal, while reposting the above to a better place, I found that Chrome has a similar tool. – Arjan Dec 29 '13 at 21:46
  • 1
    Indeed, @Amal, and the other 6 glyphs ("characters") are for "Pekka" and the space. (Also, Trebuchet is really a standard font, which on my Mac also did not include the funny guy.) Note that you could edit the page from within Chrome (just find the text in the lower left pane of your previous screenshot, double click that text, and remove the "Pekka" part) to see what the interesting character gives you. – Arjan Dec 29 '13 at 22:29
up vote 1 down vote accepted

I still am not fully sure what caused this issue but I guess that was because Chrome couldn't find the requested glyph () in the available font. Anyway, I was able to get it working. Here's what I did:

  1. Re-installed Google Chrome
  2. Re-installed system fonts:

    sudo apt-get --reinstall install msttcorefonts
    
  3. Regenerate the font cache (to avoid logout / login):

    sudo fc-cache -fv
    
  4. Install some available font-packages:

    sudo apt-get install ttf-indic-fonts-core ttf-kacst-one ttf-khmeros-core ttf-lao ttf-punjabi-fonts ttf-takao-pgothic ttf-thai-tlwg ttf-unfonts-core ttf-wqy-microhei
    
  5. Tada!

I'm just posting this if in case someone encounters this issue in future. And thanks goes to @Arjan for all the valuable advice).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .