8

I just ran across this answer while on comment patrol. It seems normal in almost every regard... Except it isn't. For one, it's cut off - look at the source and you see that there's quite a bit more that isn't shown.

Another thing: the code block formatting is.. um... overflowing:

enter image description here

I don't know if this is an injection of some kind or what, but it certainly doesn't look good for security. What's wrong?

  • Shows uncut for me, think someone edited it already after reading your post – Hanky Panky Nov 19 '13 at 4:54
  • Yup, animuson did. – Undo - Reinstate Monica Nov 19 '13 at 4:54
  • Whatever was edited out seems not visible in the edit history though? That would be weird. – Pekka supports GoFundMonica Nov 19 '13 at 4:54
  • 2
    animuson's recent edit may have "fixed" this, but the answer looks absolutely fine here. What browser/OS are you using? – Adam Lear Nov 19 '13 at 4:55
  • I think it looks kinda cool. – michaelb958--GoFundMonica Nov 19 '13 at 4:56
  • @Anna Mobile Safari, latest. – Undo - Reinstate Monica Nov 19 '13 at 4:57
  • 2
    Appears like only this was edited and removed ###Edit:, that doesn't look like it would be causing any problems before the edit? – Hanky Panky Nov 19 '13 at 4:57
  • FYI, @AnnaLear I repro'd in chat before animuson's edit (Chrome 71,000 or whatever the newest version is this hour, Windows 7). – Josh Darnell Nov 19 '13 at 4:58
8

To echo from chat: Posts are only run through the Markdown parser at the time they're posted or last edited, and the generated HTML is saved. Running every post in a question through the Markdown parser on every page load would be a huge performance hit, so it's permanently cached until it's updated or the magical beings at SE manually refresh it (if they even do that).

So whatever happened there, happened in 2009, and the post just hasn't been updated since then to fix the problem. Any bug that might have caused it is likely long gone by now, and this probably isn't reproducible anywhere else.

  • can we get this manually refreshed, please? – John Dvorak Nov 19 '13 at 5:33
  • Well, without knowing the exact posts that are actually affected by this ancient bug, that would require refreshing the entire database of posts. I don't think the devs are interested in doing that. The post in question has already been fixed, though. – animuson Nov 19 '13 at 5:47
  • Can we flag those that need a fix? – John Dvorak Nov 19 '13 at 6:14
  • 2
    You could just fix them yourself. Making any small change just so that there's a new revision will cause the post to be re-rendered through Markdown, which should fix any previous rendering issues the post might have had. That's all a moderator would do. – animuson Nov 19 '13 at 6:21
  • ... even if the post is on the verge of autowiki (9 revisions)? – John Dvorak Nov 19 '13 at 6:32
  • 2
    Then flag it after and request the wiki be removed? That's a bit of an edge-case for something that's already an edge-case itself. – animuson Nov 19 '13 at 6:34
  • 1
    OK, then. Thanks :-) – John Dvorak Nov 19 '13 at 6:35

Not the answer you're looking for? Browse other questions tagged .