1

I happened to notice a very strange scenario today when I was reviewing the suggested edits queue today. The review buttons were not displayed back after closing the reject window, rather it just used to stay as "Rejecting" and wouldn't go back to normal unless I refreshed the page. I was able to re-create this in almost every review. Here is a snapshot of what I'm talking about.

Review Buttons not displayed back

Steps to reproduce this:

  1. Go to the suggested edits review page.
  2. Click on the reject button.
  3. Press the close button at the top or press the escape key.
  4. And now you can see the buttons are not displayed back with a disabled Rejecting button.
  5. Refresh the page and tada, its back to normal again.

Is this some sort of or ? Btw, I'm using Firefox 25.0.1 on Windows 7, if that matters.

P.S: It seems that a similar(I guess the same) bug was reported long back here and it was fixed by the dev team. But now, the bug seems to have cropped up again.

  • Wow. Ninja'd... – John Dvorak Nov 20 '13 at 6:06
  • Maybe it's a deliberate bug so that we don't click that button while facing positive audits. – John Dvorak Nov 20 '13 at 6:07
  • @JonathanHobbs - Even the duplicate doesn't have any answers :( and also, I provided the steps to reproduce it :) – SudoRahul Nov 20 '13 at 6:14
  • @R.J - If the duplicate question doesn't have any answer that doesn't mean you should ask another question to get an answer or we shouldn't close the question. Also the additional information can be added in the main question. – hims056 Nov 20 '13 at 6:18
  • @hims056 - I didn't know that a duplicate was there. I saw it only after JonathanHobbs posted the link. The only duplicate I found before creating this question was this question which said status completed and I though that a new bug has been introduced once again(somehow) and thus the question. I do not mind this question getting closed as a duplicate at all. I just wasn't aware of it. – SudoRahul Nov 20 '13 at 6:20
  • @R.J - I just replied for your reply to Jonathan. :) also the steps to reproduce is in the first paragraph. – hims056 Nov 20 '13 at 6:22
  • 1
    @hims056 - No love lost anwways :P Btw, can we post a comment to Kevin(in the question I linked in my previous comment) regarding this or let the decs find it out themselves? – SudoRahul Nov 20 '13 at 6:25
  • 1
    @apaul34208 - Actually, I wasn't talking about the bug reported 9 hours back. I never knew about it. I was talking about this one. – SudoRahul Nov 20 '13 at 6:27
  • @R.J - Yes why not.. I have commented on his answer. – hims056 Nov 20 '13 at 6:28
  • oops sorry about that – apaul Nov 20 '13 at 6:30

Browse other questions tagged .