31

Description: The inbox icon and reputation icon does not open the respective boxes anymore.

Steps to reproduce:

  1. Click on the inbox icon
  2. Click on the reputation icon
  3. Click on the stackexchange icon

Now clicking on the inbox or reputation icon again won't open them until you refresh the page.

Windows 8.1, IE 11, Chrome 31

16
  • 4
    Confirmed for Chrome & Windows 7
    – Alex
    Nov 20 '13 at 15:36
  • 1
    Hmm, curious. Same on Firefox (Win7)
    – JonW
    Nov 20 '13 at 15:36
  • 1
    Reproduced on Firefox 25 on Windows 8.
    – S.L. Barth
    Nov 20 '13 at 15:38
  • 2
    This won't work for the reputation icon too. To be precise if you click both before clicking the StackExchange icon both will not open. If you only click the inbox button, the reputation icon will open as expected.
    – Marc-Andre
    Nov 20 '13 at 15:38
  • 1
    Repro Chromium on Linux Nov 20 '13 at 15:39
  • 9
    A more general procedure to reproduce: if you open the inbox panel or the reputation panel before having opened the SE panel, that respective panel will no longer open.
    – Stijn
    Nov 20 '13 at 15:39
  • 1
    That's a very peculiar bug... :) Nov 20 '13 at 15:40
  • 1
    Dr.House of web pages. Nov 20 '13 at 15:43
  • 1
    Reproed on Chrome Infinity and OS X.
    – Undo
    Nov 20 '13 at 16:07
  • 1
    I'm amazed nobody blamed caching just yet. Nov 20 '13 at 16:15
  • I guess when click the exchange icon the other boxes are hidden using CSS display: none; but then tries to open using jQuery.Show() or something similar...
    – user189175
    Nov 20 '13 at 16:17
  • Also on FF 17, Win 7.
    – RobH
    Nov 20 '13 at 17:22
  • Reproduced on Chrome 31 on Mac OSX 10.8.5. Actually once the problem starts occurring, clicking on the icon sets display:none on the topbar-dialog element instead of setting it to display:block. Looks like its hiding it instead of showing it. Test it by removing the inline display:none style on the element. Nov 20 '13 at 17:28
  • 1
    We're aware of this, and we're working on it.
    – Jeremy T
    Nov 20 '13 at 19:45
  • @JeremyTunnell status-planned then? Nov 21 '13 at 9:29
2

Forgot to update this, but a large JS refactor fixed the issue a while ago.

You must log in to answer this question.