10

This question already has an answer here:

I created a new user(this user). On my profile I can see that I have the right to ask questions. I'm not sure if this was the case last night.

I tried to ask a question, but got a message back saying my question appears to be spam. I don't think this is because of the structure of my question, the only reason I can think this was is because I had the wrong date on my machine. I changed it to February for testing purposes.

This morning I tried to post the question again, with the correct date on my machine. I get a popup, which I assume is an error message, I can't read it though because it only says

object Object

Any ideas as to why this could be or what I can try to fix this?

Edit: After trying to submit it a couple of times trying to catch the exception I'm getting the "Your question appears to be spam." error again. I assume this is because I've tried multiple times from the same IP/user?

The fact that I can post questions here tells me that the content of my question might actually be the problem, but without a clear indication as to what the problem is I'm a bit baffled. As far as I can see I'm following the template exactly.

Edit2: Here is the text of the question I'm trying to post(if it works here then I'm stumped):

I'm using jsf 2.1 and I'm experiencing some problems with the h:link tag. I'm trying to have the link's outcome point from my xhtml file to another html file. However, when I run my web application, the source is automatically converted to an xhtml extension.

Here is my xhtml file:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"
  xmlns:h="http://java.sun.com/jsf/html"
  xmlns:f="http://java.sun.com/jsf/core"
  xmlns:ui="http://java.sun.com/jsf/facelets">

<h:head>
  <title>MyPage</title>
</h:head>

<h:body>
  <h:form>        
      <h:link value="animation" outcome="#{contentForm.ccAnimationLink}"/>            
  </h:form>
<h:body>

Here is my contentForm bean:

package my.app.content;

import java.io.Serializable;
import javax.annotation.PostConstruct;
import javax.faces.bean.ManagedBean;
import javax.faces.bean.ManagedProperty;
import javax.faces.bean.RequestScoped;

@ManagedBean
@RequestScoped
public class ContentForm implements Serializable {
  private static final long serialVersionUID = -8463354828156798513L; 
  private String ccAnimationLink = "";    

  @PostConstruct
  public void init() {        
      ccAnimationLink = "/content/cc/CC_animation/story.html";        
  }

  public String getCcAnimationLink() {
      return ccAnimationLink;
  }

  public void setCcAnimationLink(String ccAnimationLink) {
      this.ccAnimationLink = ccAnimationLink;
  }
}

Now, when I run this application, I get the following error:

Unable to find matching navigation case from view ID '/content/modifiedcc.xhtml' for outcome '/content/cc/CC_animation/story.html'

I made sure that I had the url correct, so I created a story.xhtml file in that location as well. With that file there it runs without errors.

If I pull the source for the generated page, I can see that the h:link was correctly changed to an "a href" tag, as follows:

<a href="/MyWebApp/content/cc/CC_animation/story.xhtml">animation</a>

For some reason though the url change from story.html, like I have it in my bean, to story.xhtml.

How can I make sure that it stays as story.html and not change it to xhtml?

For what it's worth, here is my web.xml file as well:

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee"

xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd" id="WebApp_ID" version="3.0"> MyWebApp javax.faces.PROJECT_STAGE Development jsf/login/login.xhtml Faces Servlet javax.faces.webapp.FacesServlet 1 Faces Servlet /faces/ Faces Servlet .jsf Faces Servlet .faces Faces Servlet .xhtml

I'm sure this has a very simple solution which I'm just missing right now. Help would be highly appreciated. I hope the question is clear.

marked as duplicate by m0sa Dec 2 '13 at 7:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 4
    Could you post the text of the question? – John Palmer Dec 1 '13 at 6:52
  • So I can post it on this forum, but not where I'm supposed to post the question. – Frost Dec 1 '13 at 7:19
  • 2
    All I can think is that there are a lot of URLs, maybe that is tripping the spam filter? – John Palmer Dec 1 '13 at 7:56
  • Thanks @JohnPalmer, that was the problem. – Frost Dec 1 '13 at 8:09
  • @JohnPalmer post this as answer please, but I think that URLs inside code blocks should not affect the spam filter... bug report may be due. – Shadow The Dragon Wizard Dec 1 '13 at 8:27
  • 1
    Also, this is not a forum, it's a Q&A site. – user1306322 Dec 1 '13 at 8:32
  • The duplicate is unrelated. Voted to re-open. – yannis Dec 1 '13 at 9:01
  • @Yannis yep, that other report is about the "object Object" popup. – Shadow The Dragon Wizard Dec 1 '13 at 9:10
6

From the comments it appears that the spam filter was tripped by the large number of URLS

It is possible that this is a bug

  • 2
    Even if this isn't a bug, it desperately needs a more informative error message. – yannis Dec 1 '13 at 8:47
  • @Yannis I am pretty sure this one is supposed to display a captcha? – Aza Dec 1 '13 at 8:52
  • @Emracool Hm? Why? A captcha won't prevent human spammers. There's a two-links-only limit for brand new users (less than 10 rep), and I think that's what stopped the post from going through. – yannis Dec 1 '13 at 9:00
  • @Yannis Ah, huh, didn't know about the link limit. Nevermind, then! – Aza Dec 1 '13 at 9:04
  • 1
    @Emracool It's part of the new user restrictions. However, I'm not entirely sure those restrictions are to blame here. It's possible there's an additional anti-spam filter that works the same for all users, regardless of rep. – yannis Dec 1 '13 at 9:06
  • @Yannis Fair. I have encountered a topic I don't know about, so it is my time to bow out. Looking through this, though; thanks! – Aza Dec 1 '13 at 9:10

Not the answer you're looking for? Browse other questions tagged .