4

The original question: Google Transit API bus stops in route invisible and on the map disabled

I can't get information from clicking the bus stops although the city has them when I enter >in Google Maps, but implementing it myself doesn't work. They are disabled. I'm having a >similar problem to another post: Enable bus stop icons clickable in Google Maps

Also when I create a route my stops between the origin and destination don't appear, these >white dots are invisible, but if I click in the instructions in the panel this window opens >with the information needed.

I've tried out putting transit layer and nothing appears in my jQuery Mobile app.

So it was a two part question; "why can't I get interactivity through the map api", and "why am I having trouble displaying dots". The op accepted his own answer to the question, but it was a self-admitted partial answer to the dots display problem.

The first part of his question about the google maps api has an answer, and that is that it's a known bug. I provided a link to the bug location, and my answer got deleted without comment.

I've been working on transit layers for a couple of days and noticed what I think is the >s=ame problem: Bus/Train icons not being interactive. At some levels of zoom icon->mouseovers are working for my app, but not all.

This seems to be a legitimate bug, per: https://code.google.com/p/gmaps-api->issues/issues/detail?id=145.

Even in the official Maps api code demo of a transit layer for London, the transit icons >are non-interactive, while on map.google.com they are clickable: >https://developers.google.com/maps/documentation/javascript/examples/layer-transit.

It's a bit frustrating for a first-time user attempting to contribute: I'd appreciate any pointers as to what I did wrong.

  • 4
    If I'd have to guess, I'd go for that it sounds a bit like a "Hey, I have the same problem" comment, rather than an actual answer. – Bart Dec 4 '13 at 21:19
6

You didn't post an answer. We're looking for answers, not clarifications. Clarifications belong more properly in comments.

This sort of thing happens all the time in other online forums, and it's the very thing that we're trying to avoid here: people posting all sorts of observations, speculations and ruminations; posting anything and everything, except for an actual solution to the problem.

  • It seems a bit harsh though. If it were phrased like "I encountered the same problem, and it turns out to be a bug", would that more determined statement have been deleted? – Bart Dec 4 '13 at 21:21
  • 1
    "I have the same problem" probably triggered the deletion in the first place. – Robert Harvey Dec 4 '13 at 21:22
  • Myeah, hence my initial guess. – Bart Dec 4 '13 at 21:22
  • I fully understand the "we're looking for answers" mindset...but his question was "why can't/how do I get interactivity?" My response was that he couldn't get interactivity because it's a problem with the API code iteslf, as acknowledge by the gmaps team. It's seems to me that I answered his question. Should I have just worded it more strongly: "You can not get the functionality out of the api that you are expecting?" – PBoillot Dec 4 '13 at 21:24
  • 4
    Yes, that would have been better. I went ahead an undeleted your answer. In the future, you can dispute a deletion by casting a custom moderator flag on the answer and explaining the problem. – Robert Harvey Dec 4 '13 at 21:26
  • 1
    @PBoillot Yes, you probably should have worded it that way. Even if it's an answer now, it'd be a better answer if you worded it that way. – Servy Dec 4 '13 at 21:26
  • Thank's for the clarification, I will edit my answer to reflect what I've learned here. Sidenote: are there any sort of best-practices for moderator deletion? A short message explaining the original problem with my response would've helped me out. – PBoillot Dec 4 '13 at 21:27
  • There's a "Why was your post deleted" link in the moderator-deleted answer that explains the specifics. – Robert Harvey Dec 5 '13 at 0:23
  • I read and re-read that link before I posted my question here, but I didn't understand what had happened until I did. The help-center link explains the general guidelines behind acceptable answers, and some of the causal chains leading to post deletion...but the specifics seem to have been "you worded your response poorly to make it seem as if it didn't contain an answer." The post was deleted, presumably, for unacceptably uncertain vocabulary. That's all I mean; an annotation as short as "unacceptably vague/uncertain" would have clued me in, that help center link is unspecific. – PBoillot Dec 5 '13 at 4:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .