26

Title was: Please turn off autocorrect entirely if a line begins with four spaces.

My morning so far.

space space space space p [ i ] oops it autocorrected to p[I], so backspace backspace i ] dammit it did it again CTRL-Z What the heck CTRL-Z does not undo autoformatting as is right and just!!! Forget it, I'll use j.

So, three feature requests.

  1. Turn off autoformatting entirely if a line begins with four spaces.

  2. Immediately after an autoformatting, any use of backspace should temporarily turn off autoformatting. The user is backspacing because they didn't like your decision. Don't repeat it.

  3. CTRL-Z should undo the last action. Autoformatting is an action.

UPDATE: Apparently some people are having difficulty reproducing this. I am typing answers to C questions in StackOverflow, specifically: How to assign a pointer to another pointer of different type

I'm at my desktop machine using IE 10 as the browser.

UPDATE: Doesn't repro on Chrome. Good heavens, is IE doing this to me???

UPDATE: AAARGH IE 10 turned on spelling autocorrection by default.

OK SO, this one is on Microsoft, not on you. Microsoft should know better than to make CTRL-Z work differently in VS, Word and IE. I will send them a sternly worded letter.

Sorry for the spam. I'll self-answer this one so that the next time someone is tricked by this, they'll hopefully find me looking foolish. :-)

  • 5
    Is autoformatting a thing? Where does this happen? – p.s.w.g Dec 20 '13 at 16:08
  • 2
    Are we talking about mobile? My desktop certainly doesn't do this. – Geobits Dec 20 '13 at 16:09
  • @p.s.w.g: Start writing an answer on StackOverflow and see what happens when you type what I typed. – Eric Lippert Dec 20 '13 at 16:09
  • 2
    @EricLippert Yeah I tried it, this has never happened for me. – p.s.w.g Dec 20 '13 at 16:09
  • @GenericHolidayName: I'm sitting at my desk right now. – Eric Lippert Dec 20 '13 at 16:09
  • 1
    Regarding update, even on the same question, same browser, I can't repro. I... don't think this is an SO thing. – Geobits Dec 20 '13 at 16:12
  • 2
    Reproduced using IE 11 on Stack Overflow and here on Meta, not with Chrome. – Oded Dec 20 '13 at 16:14
  • 5
    Does your browser look something like this? If it does, that could be the problem. – SeanWM Dec 20 '13 at 16:14
  • 4
    It's IE. It's a feature. It's to force you to paste code from VS or notepad instead of composing in place :-) – Kate Gregory Dec 20 '13 at 16:15
  • 2
    "...this one is on Microsoft" It's always on Microsoft. – SeanWM Dec 20 '13 at 16:18
  • 2
    This question will make a great resource to give to people suffering from impostor syndrome... If Eric Lippert can ask a dumb question, there's hope for us all! – AakashM Dec 20 '13 at 16:22
  • 3
    At least it wasn't localization. – Tim Post Dec 20 '13 at 16:22
  • 4
    @AakashM: There are no dumb questions, only dumb people. And no dumb people use Stack Overflow. (Of course ignorant people use SO all the time.) – Eric Lippert Dec 20 '13 at 16:23
  • 3
    @ThisSuitIsBlackNot: You may want to look up Eric's career history. If anyone on Stack Overflow has a chance to be heard on this issue, I'd have Eric at the top of that list. – Martijn Pieters Dec 20 '13 at 16:33
  • 1
    @MartijnPieters: I haven't worked with the IE team since 2001; what limited pull I ever had there is long gone now. – Eric Lippert Dec 20 '13 at 16:36
26

Autocorrect of i to I is a feature of Internet Explorer 10 which is turned on by default.

To turn it off, go to the Tool icon, then Manage add-Ons, then click Spelling Correction and then uncheck the Enable spelling correction checkbox that appears.

  • 4
    Enjoy another 10 imaginary points. Props for hunting down the issue. – GlenH7 Dec 20 '13 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .