1

I've been experiencing some weird behavior using stack exchange sites -- all of them. The problem is I can't simply gain access to the sites, for example, when I'm looking for some info typing words in google, I often see results that link to superuser (and other stack exchange sites). But when I click on that link, the site isn't loading, at least not instantly. It takes it about 5-7min to load and, of course, it's not fully loaded, just text, even there's no css. I can refresh it and after 2nd or 3rd time I can freely browse superuser, and then it works just fine. But when I close my browser and try to visit the site latter, everything starts anew.

I tried checking if something is wrong with my internet config, but everything seems to be fine. When I use vpn that points to the US and connect to the site through it, it works as expected. But when I try turning it off, I loose access immediately, and I have to wait some minutes in order to see something there. The same thing is when I try to use pastebin.com . I don't know maybe it's related.

I'm using a linux system (debian testing). I have also opendns service enabled with encrypted DNS requests. But I checked google DNS, my own ISP DNS, and it doesn't matter.

I share IP (82.160.125.13) with some hundreds of people -- it's not my ip, I don't have an external IP. Most of sites on the internet works without a problem. Most, but not all of them. I also have some problems with sites behind cloudflare -- I often have to prove that I'm not a bot. I know that this IP exists on some blacklists, maybe here's the problem?

I have also ipv6 disabled in kernel by passing the following parameter to the kernel at boot:

ipv6.disable=1

According to http://debug-02.netdna-cdn.com/ , I'm hitting the NetDNA Frankfurt Datacenter .

Traceroute shows different results. Mostly there's no answer after cloudflare-ic-154353-war-b2.c.telia.net and it looks like this:

# traceroute --tcp cdn.sstatic.net
traceroute to cdn.sstatic.net (190.93.245.58), 30 hops max, 60 byte packets
 1  192.168.22.51 (192.168.22.51)  9.480 ms  9.390 ms  9.425 ms
 2  192.168.22.51 (192.168.22.51)  9.384 ms  9.410 ms  9.365 ms
 3  gigant.mast1.isko-tktelekom.isko.net.pl (82.160.125.1)  9.768 ms  9.768 ms  9.755 ms
 4  213.199.236.17 (213.199.236.17)  12.428 ms  12.421 ms  12.423 ms
 5  war-b2-link.telia.net (213.248.97.117)  11.103 ms  11.123 ms  11.089 ms
 6  cloudflare-ic-154353-war-b2.c.telia.net (80.239.194.90)  11.051 ms  8.854 ms  9.078 ms
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Sometimes it looks like this:

# traceroute --tcp cdn.sstatic.net
traceroute to cdn.sstatic.net (190.93.245.58), 30 hops max, 60 byte packets
 1  192.168.22.51 (192.168.22.51)  8.198 ms  8.186 ms  8.173 ms
 2  192.168.22.51 (192.168.22.51)  8.158 ms  8.171 ms  8.069 ms
 3  gigant.mast1.isko-tktelekom.isko.net.pl (82.160.125.1)  8.495 ms  8.489 ms  8.430 ms
 4  213.199.236.17 (213.199.236.17)  13.915 ms  13.915 ms  13.828 ms
 5  192.168.22.51 (192.168.22.51)  7.938 ms !H war-b2-link.telia.net (213.248.97.117)  9.765 ms  9.253 ms

And even like this:

# traceroute --tcp cdn.sstatic.net                                                                                                           
traceroute to cdn.sstatic.net (190.93.244.58), 30 hops max, 60 byte packets
 1  192.168.22.51 (192.168.22.51)  7.463 ms  7.358 ms  7.394 ms
 2  192.168.22.51 (192.168.22.51)  7.340 ms  7.354 ms  7.341 ms
 3  gigant.mast1.isko-tktelekom.isko.net.pl (82.160.125.1)  7.447 ms  7.440 ms  7.436 ms
 4  213.199.236.17 (213.199.236.17)  12.603 ms  12.595 ms  8.910 ms
 5  war-b2-link.telia.net (213.248.97.117)  8.831 ms  8.830 ms  8.816 ms
 6  cloudflare-ic-154353-war-b2.c.telia.net (80.239.194.90)  9.211 ms  10.783 ms  11.270 ms
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  192.168.22.51 (192.168.22.51)  7.972 ms !H * *

This works ok:

# traceroute --tcp sstatic.stackexchange.netdna-cdn.com
traceroute to sstatic.stackexchange.netdna-cdn.com (67.215.65.132), 30 hops max, 60 byte packets
 1  192.168.22.51 (192.168.22.51)  8.880 ms  8.786 ms  8.819 ms
 2  192.168.22.51 (192.168.22.51)  8.706 ms  8.759 ms  8.714 ms
 3  gigant.mast1.isko-tktelekom.isko.net.pl (82.160.125.1)  8.906 ms  8.898 ms  8.892 ms
 4  213.199.236.17 (213.199.236.17)  12.764 ms  12.756 ms  12.760 ms
 5  xe-8-3-0.waw10.ip4.tinet.net (141.136.97.97)  61.691 ms  61.693 ms  61.682 ms
 6  opendns-gw.ip4.tinet.net (141.136.101.126)  9.625 ms  11.599 ms  11.582 ms
 7  hit-nxdomain.opendns.com (67.215.65.132)  8.681 ms  8.662 ms  8.657 ms

Same here:

# traceroute --tcp sstatic.net
traceroute to sstatic.net (198.252.206.16), 30 hops max, 60 byte packets
 1  192.168.22.51 (192.168.22.51)  7.170 ms  6.873 ms  6.884 ms
 2  192.168.22.51 (192.168.22.51)  7.118 ms  7.114 ms  7.050 ms
 3  gigant.mast1.isko-tktelekom.isko.net.pl (82.160.125.1)  7.265 ms  7.261 ms  7.202 ms
 4  213.199.236.17 (213.199.236.17)  16.414 ms  16.663 ms  16.661 ms
 5  war-b2-link.telia.net (213.248.97.117)  12.101 ms  12.114 ms  12.079 ms
 6  hbg-bb2-link.telia.net (213.155.133.94)  27.522 ms  24.592 ms  24.555 ms
 7  nyk-bb2-link.telia.net (80.91.247.123)  116.806 ms nyk-bb2-link.telia.net (80.91.247.125)  117.674 ms  107.557 ms
 8  nyk-b6-link.telia.net (213.155.130.251)  105.307 ms  106.271 ms  107.408 ms
 9  internap-ic-150761-nyk-b5.c.telia.net (213.248.81.150)  107.816 ms  107.793 ms  107.253 ms
10  border1.po1-20g-bbnet1.nym008.pnap.net (216.52.95.1)  107.904 ms  110.846 ms  110.801 ms
11  stackexchange-1.border1.nym008.pnap.net (74.201.252.22)  107.230 ms  105.751 ms  106.116 ms
12  stackoverflow.com (198.252.206.16)  105.583 ms  105.350 ms  104.862 ms

Is there something I can do about it?

  • Haven't you got IPv6 from your ISP? You should enable it. – Michael Hampton Dec 27 '13 at 5:41
  • No, I think I don't have ipv6. My ISP said once that it's better to turn it off. So, I did it. – Mikhail Morfikov Dec 27 '13 at 6:01
  • Well, since it seems that your ISP are full of morons who have no idea how to deploy a network properly, I'm not sure about their advice :) – Michael Hampton Dec 27 '13 at 6:04
  • I removed the kernel parameter. The issue still exists, but now it hangs with cdn-prom.sstatic.net. – Mikhail Morfikov Dec 27 '13 at 7:46
  • I've been testing the connection to the site, and it's better, no doubt, but I still have the issue with cdn-prom.sstatic.net and cdn.sstatic.net but in many cases when I try to visit superuser, everything works fine. – Mikhail Morfikov Dec 29 '13 at 5:25

You must log in to answer this question.

Browse other questions tagged .