4

When using an android phone (in this case my HTC One running android 4.3 and Chrome browser) whenever I need to migrate a question I can select the 'Migration' option but can't clear all the placeholder text. It just adds itself back in when i've cleared it out.

Selecting the field makes the 'type to search' text selectable. Should I clear it out and then start typing in there the 'type to search' text adds back into the field next to where i've typed. So in effect I end up with 'stack overflowtype to search' showing in the field that I then have to move the cursor to the end of the text and delete the supplementary text.

enter image description here

Now this is annoying.

It would be annoying if it were on a desktop where I have a mouse to help me, but with my fingers jabbing at a text cursor in a small field several times it drives me crazy.

So my suggestion is - Please remove the placeholder. There isn't really a Label on that field anyway, so for accessibility purposes there really should be one. So perhaps set 'Type to Search for a Stack Exchange Site' as the field label.

Or just scrap the placeholder anyway. People with the rep to do a migration should know how these sites work anyway, so it's arguable that it's redundant text anyway. But I suggest having it as a proper form label instead.

Note, I've seen this post (below) but it doesn't seem to be the same issue that I have.

Can't select "migrate to" destination when browsing on Android phone

  • What browser exactly are you using? Sounds like the browser is not supporting HTML 5. – Shadow The Curly Braced Wizard Jan 6 '14 at 14:00
  • It's the Chrome browser on the phone, which does support HTML5 . I don't think the placeholder itself is an actual html5 placeholder, I think it's using JavaScript or something (can't really tell as the whole modal popup doesn't work without JS so I can't test that easily as I can't even access it without script). And there are some blur effects going on too. – JonW Jan 6 '14 at 14:03
  • That's weird... if they have custom placeholder I agree it should be removed or replaced with standard HTML 5. By the way, this is moderator only tool, adding proper tag. – Shadow The Curly Braced Wizard Jan 6 '14 at 14:04
  • @ShadowWizard yeah, that's why I tagged this 'accessibility' too as it's not really ideal the way it's been put together. – JonW Jan 6 '14 at 14:06
1

Since this is a moderator tools (IE9- compatibility is not a big concern in that case) I've replaced the JS fiddlery with a html5 placeholder. The fix will be with you in build rev 2014.3.28.2099 on meta and 2014.3.28.1498 on sites.

  • Ah, great. I look forward to migrating unsuitable questions to the wrong sites from my phone with ease then! – JonW Mar 28 '14 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .