I answered a question and tried to edit that as per OP's comment on my answer.

But when I click on 'Save Edits' after editing, I get an error saying An error occurred submitting the answer


enter image description here

I already searched. I got this answer which says that SO must be in read only mode. But I could edit my other post without any issue. Why am I getting this problem?

  • 1
    This usually happens to me when I'm on an intermittent internet connection – Richard Tingle Jan 8 '14 at 11:44
  • @RichardTingle But I could edit other post, and after editing that post tried to edit that answer again, but same error. So may be Internet connection is not an issue. – MysticMagicϡ Jan 8 '14 at 11:46
  • Interesting, I just tried to edit that post and it was successful, what exactly did you try to edit in. Was it <action android:name="android.intent.action.NEW_OUTGOING_CALL" /> and was it code formatted? – Richard Tingle Jan 8 '14 at 11:48
  • Yes, noticed that you edited for testing. Yes, I tried to add that in code, and it was well formatted. @RichardTingle – MysticMagicϡ Jan 8 '14 at 11:50
  • Strange, I know code not formatted as code can upset it but the code formatting is supposed to prevent this – Richard Tingle Jan 8 '14 at 11:51
  • Finally I could edit that post. But question still remains, why was I not able to edit that previously? – MysticMagicϡ Jan 8 '14 at 11:51
  • 1
    @RichardTingle In unformatted code's case, it shows error saying that there is unformatted code (as far as I remember. It had happened a year ago, so can't recall.) – MysticMagicϡ Jan 8 '14 at 11:52
  • 1
    I think there are two kinds of unformatted code problems; one where it identifies it, doesn't like it and tells you. And annother where it doesn't identify it, thinks it's its own code and chews it up leading to assorted problems – Richard Tingle Jan 8 '14 at 11:53
  • Hmm. May be. I think only developers can tell the precise issue. – MysticMagicϡ Jan 8 '14 at 11:54
  • Probably true, but as the problem has resolved itself it may be difficult for them to identify – Richard Tingle Jan 8 '14 at 11:55
  • Maybe it was temporary glitch, maybe you have some rough user script... – Shadow The Burning Wizard Jan 8 '14 at 11:56
  • May be. I had faced same issue before 3 days, but ignored it and continued with other work. As this happened second time today, I thought to ask a question. – MysticMagicϡ Jan 8 '14 at 11:57

Looks like edit wars. You've been submitting an edit to your first (old) revision, while the current revision (edited by another user) was already this.

  • No. Because Richard edited that post for testing after I posted this question. – MysticMagicϡ Jan 9 '14 at 4:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .