6

I noticed beginning today that I'm receiving ssl_error_illegal_parameter_alert on various stack exchange sites. I've encountered the error so far on Stack Overflow, Meta Stack Overflow, and Superuser. The error itself doesn't appear to occur on the *.stackexchange.com sites, but I can't guarantee that as I've not spent much time trying to reproduce it there. I've never had problems with Stack Exchange before this.

For more info, I'm currently running Firefox Nightly 29.0a1 with HTTPS Everywhere, Ghostery, and NoScript.

The actual error page:

enter image description here

Any ideas?

  • 2
    There are reports about this happening if you have Kaspersky AV installed with Web Control enabled, if that's applicable to your situation. SSL isn't officially supported yet on the Stack Exchange network, so you might want to disable the HTTPS Everywhere rule for as a workaround for the time being, but this is presumably a client-side issue. I don't have a nightly Firefox build to test with, but I can't repro in my environment. – Tim Stone Jan 8 '14 at 15:08
  • There's a thread on Mozilla support about this too - support.mozilla.org/en-US/questions/980582 it does appear to be Kaspersky. – JonW Jan 8 '14 at 15:19
  • @TimStone Would appear to be a Kaspersky problem after all. My company uses Kaspersky Endpoint Security 8. Oddly enough, I thought I'd already disabled it entirely on my system, but Web Control was still enabled. Thanks. If you'd like to add that as an answer, I'll accept it. – DanteTheEgregore Jan 8 '14 at 15:20
5

There are reports about this happening in Firefox if you have Kaspersky AV installed with Web Control enabled. Other antivirus software may also have similar problems when integrating with new/unstable browser builds, so that's worth looking into.

You can also disable the HTTPS Everywhere rule as a workaround for the time being, because the Stack Exchange network doesn't officially support SSL anyway (and as a result you get a lot of mixed content, and some things like authentication and closing as duplicate don't work correctly).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .