6

I was briefly in the Game Development chat (DO NOT CLICK HERE OR YOU WILL BE TRANSPORTED INTO THE NINTH CIRCLE OF HELL) early today, and although I'd closed the tab, i noticed I was still listed as in that room.

I'm in Game Development

So I decided to leave. I clicked the little icon and then OK.

Yes, get me out of there!

Sure enough, I left Game Development...

but not for long!

But only for a few seconds. Within five seconds, it mysteriously reappeared!

Is this Game Development or a circle of hell?

For the avoidance of doubt, I left all other chat rooms as well, and successfully. It's only Game Development that I can't leave. I have no other tabs open with chat windows.

Interestingly, sometimes I can leave it, or so it would appear - but only as long as I don't click Rejoin Favorite Rooms. If I am stupid enough to do that, I get rejoined to it, even though it is not one of my favorite rooms! If I am in some of my favorite rooms, then I just get rejoined to Game Development immediately. (Note that some of my favorite rooms are private rooms and I'm not showing them to all of you.)

I am using Firefox 26 on Linux (Fedora 20, KDE). Also, to the best of my knowledge, I have not attempted to parse any HTML with regex lately.

closed as off-topic by yannis, hims056, Martijn Pieters, apaul, ale Jan 17 '14 at 13:10

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The problem described here can no longer be reproduced. Changes to the system or to the circumstances affecting the asker have rendered it obsolete. If you encounter a similar problem, please post a new question." – yannis, hims056, Martijn Pieters, apaul, ale
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 12
    ... you can check-out any time you like, but you can never leave ... – yannis Jan 17 '14 at 9:34
  • Do you have the chat room open in any other windows, on any other devices (phone, tablet) etc? I generally experience this issue when I leave a chat room on my PC but my tablet is still in the room - the next time it checks for messages I get rejoined to the room on all devices. – Flyk Jan 17 '14 at 9:37
  • I don't use chat from any other devices, at all, ever. – Michael Hampton Jan 17 '14 at 9:38
  • 1
    I know mobile chat is bad but you don't need to avoid it so much! :P – Flyk Jan 17 '14 at 9:39
  • If I don't get out of Game Development chat soon, I am going to start subjecting everyone in there to ---Team Foundation Server--- moderation. And you don't want that... – Michael Hampton Jan 17 '14 at 9:46
  • 1
    you got markdown'd – tombull89 Jan 17 '14 at 9:50
  • From the database, I can indeed see you repeatedly joining this morning - but: I think this is specific to you (it doesn't seem to affect other folk as far as I can tell). Unfortunately I don't have enough data in that table to see where it is coming from - are you sure you don't have other browsers etc open? (note: it would also need them to be glitching - normally if you leave from anywhere, all connected clients as "you" will follow the same action) – Marc Gravell Jan 17 '14 at 9:59
  • Hmm. I closed Firefox, but found a hung Firefox process that wouldn't respond to anything but kill -9. We'll see if that helps... – Michael Hampton Jan 17 '14 at 10:03
  • Well, Firefox is definitely acting strangely today. Now I don't seem to be in Game Development, but I can't rejoin favorite rooms at all, so I can't really be sure! Whatever the issue is, it's clearly with this local browser, and I suppose you all can downvote me into oblivion now. – Michael Hampton Jan 17 '14 at 10:07
  • @MichaelHampton I've also just kicked our web-socket server in case that was part of the problem – Marc Gravell Jan 17 '14 at 10:07
  • Oh, well that's why I couldn't rejoin favorite rooms. I can now. No sign of Game Development, so ... problem solved? – Michael Hampton Jan 17 '14 at 10:07
  • It's pretty common to still be in rooms (or have them reappear once or twice) after leaving. Leave doesn't work very well on SE chat. – snailcar Jan 18 '14 at 2:16
10

This appears to have been caused by Firefox misbehaving.

While I had quit Firefox, I discovered a still-running Firefox process with no associated window which I had to resort to kill -9 to get rid of. Once I did so, SE chat is behaving normally again.

  • 6
    as is so frequently the case, the age-old advice of "have you tried rebooting your computer?" would have worked wonders here ;p – Marc Gravell Jan 17 '14 at 10:56

Not the answer you're looking for? Browse other questions tagged .