14

The black avatar image background bug that "Alan at IMGUR" (via Geoff Dalgas) said was fixed last March isn't. Apparently, however, whether or not it gets triggered depends on the exact method used to upload the image.

Uploaded "from my computer" Uploaded "from the web" Copy-and-pasted from the web Drag-and-dropped from my computer

The four recycling signs above are all copies of this image from Wikimedia Commons, scaled down from 200px to 128px by Imgur. All were uploaded using the "add image" popup (with the ?s=128 parameter added to the URLs afterwards), but with different methods:

  1. The first image was uploaded "from my computer", using the file selector dialog.
  2. The second image was uploaded "from the web", pasting the original URL directly into the input field.
  3. The third image, which does not suffer from the bug, was copy-and-pasted into the dialog from another browser tab.
  4. The fourth image was drag-and-dropped into the dialog from my desktop.

FWIW, I'm currently using Google Chrome 32.0 on Windows 7.

Ps. Thanks to Shadow Wizard for realizing that the upload method might make a difference; I'd honestly never have thought of that on my own. (I'm pretty sure writing this bug report was the first time I'd ever even used the methods 2–4.)

  • 2
    +1 for the credit! (and for well written bug report ;-)) also worth to mention that Paste option works only in Chrome. – Shadow Wizard Jan 18 '14 at 21:19
  • Does anyone know if someone took care of this? It looks like transparency is still not working in profile pictures. – Hexaholic Jun 20 '16 at 14:08

You must log in to answer this question.

Browse other questions tagged .