3

On the profile page there is the "my logins" link, which shows you all of the various IDs you can use to log into your Stack Exchange account.

I am trying to add a Stack Exchange account to this so that I can log in to Stack Exchange using my Google account or using a Stack Exchange username/password combination. However, this isn't working and I don't think it's something I'm doing wrong.

This is what I'm doing:

  • Go to profile (on gaming.stackexchange.com, most likely any other site not using the new login page - I haven't tested this on MSO)
  • Click my logins
  • Click add login
  • Click Stack Exchange
  • Enter an email address not currently associated with the login address of any account
  • This then creates a new account, that isn't linked to my existing account in any way

If I try to add an existing Stack Exchange login to my account I get a prompt stating "this will log out you and log you in as " with two options - to continue (and log out of my current account and log into a test account) or to cancel (and remain logged in as me).

Neither of these workflows seem to result in adding a new login to my account, and I can still only log in with my Google account.

This issue only occurs when adding a Stack Exchange login - if you attempt to add any other provider this will work fine.

What's going wrong here?

  • Are you doing that from meta.stackoveflow.com/login? – rene Jan 22 '14 at 14:09
  • 1
    You may have two separate accounts already - one with each openID. You can confirm by logging out and trying to login with each. If that's the case, request an account merge. – Oded Jan 22 '14 at 14:12
  • @Oded I do have two accounts, however in the instance where I tried to add a login I was using an email address that wasn't linked to either of them - in this instance I would have expected this to create a new account which was already linked to my existing account but neither did the login get created, did an account get created, or did an email get sent – Flyk Jan 22 '14 at 14:13
  • @rene No, nothing to do with the new login system, this was tested on arqade.com/login – Flyk Jan 22 '14 at 14:14
  • When you go to openid.stackexchange.com, are you logged in? – Oded Jan 22 '14 at 14:15
  • @Oded nope, but I can log in with the credentials for my second account. – Flyk Jan 22 '14 at 14:18
  • Maybe this wasn't really fixed as the OP thought? – Shadow The Princess Wizard Jan 22 '14 at 15:31
  • This has been gone through in detail so Stack Exchange are aware of the issue - this does actually kinda fix itself once the two accounts get noticed and merged together, but the process should be more user friendly and actually do what it says it's going to do. – Flyk Jan 22 '14 at 15:33
  • 1
    This simply does not work for me either. I'm trying to add a single Google account as a new login. I log in using Yahoo and when I try to add a Google login, it seems to silently succeed but then "my logins" never shows it. – Jesse Slicer Sep 26 '14 at 5:58

You must log in to answer this question.

Browse other questions tagged .