Lately I've been having issues posting to the Electronics Stack Exchange site. I can post comments but not ask or answer questions. It usually starts with the WYSIWYG editor not working. When I try to post, I keep getting the "Human Verification" squid, but it won't give me the CAPTCHA to verify. The progress boxes just cycle.

Trying to go to meta.electronics.stackexchange gives me an SSL error. Even if I bypass it, I'm not able to post. This error was corrected by disabling HTTPS Everywhere. But this did not fix the issue with the CAPTCHA.

Other Stack Exchange sites are working as expected though.

Since I can't post to any of the Electronics sites, I entered the chat and the moderator there told me to try posting here. He noted that my IP address changes often which it does. Since my job blocks Imgur, I switch to a proxy to see images. I understand that this is what is causing the system to flag me (I am still not sure why this doesn't occur on other Stack Exchange sites though) and that's fine. But I still am unable to prove I'm human.

Occasionally logging out, clearing all my browser data and waiting for an hour or two before logging back in will resolve the problem, and I can post as normal. But not always.

Why isn't the CAPTCHA displaying so that I can prove my humanity?

  • It seems odd that this would only be happening on EE. Have you tried one of the other sites (besides Meta)? – Robert Harvey Jan 23 '14 at 16:56
  • Do you have any browser extensions, such as RequestPolicy or NoScript, which might be blocking third-party content or scripts? Related: meta.christianity.stackexchange.com/q/3343/214 – TRiG Jan 23 '14 at 16:57
  • @RobertHarvey The main EE and the EE meta do not work. SO, meta.SO, and robotics all work normally. – embedded.kyle Jan 23 '14 at 16:58
  • 7
    I do notice an increased number of Captchas when I post to EE. Perhaps the robots are running the show over there. – Robert Harvey Jan 23 '14 at 16:59
  • @TRiGisTimothyRichardGreen I do not have those particular extensions. Though I do have AdBlock. I will try disabling that next. I tried a suggestion from the comments in this post: meta.stackexchange.com/questions/145051/… of going directly to: google.com/recaptcha/api/… and I can see the CAPTCHA there no problem. – embedded.kyle Jan 23 '14 at 17:00
  • @TRiGisTimothyRichardGreen Same problem with *.stackexchange.com/* excluded from AdBlock – embedded.kyle Jan 23 '14 at 17:03
  • @RobertHarvey Funny. Of all the places for the robots to be running the show you would think it would be robotics.SE. And yet I can post there just fine. – embedded.kyle Jan 23 '14 at 17:05
  • "Trying to go to meta.electronics.stackexchange gives me an SSL error." Well, that sounds like you have HTTPS Everywhere, and should disable the rule for the Stack Exchange network...but I don't know if that's causing your other problems. – Tim Stone Jan 23 '14 at 17:09
  • @TimStone Ah yes. Forgot to mention that. I do have HTTPS Everywhere and I did disable it while chatting with the Mod. This does fix the SSL error. But not the CAPTCHA error. – embedded.kyle Jan 23 '14 at 17:12

You must log in to answer this question.

Browse other questions tagged .