4

So I tried to play with the new login page in meta when trying to help another user understand the login system.

Currently, I have a Google account and a Stack Exchange account and am logged in with both

Screen shot of my logins

I clicked "add more logins" and from the new login screen, I clicked sign up

Screen shot of new style login/signup page on meta

Here's where things went goofy.

I tried to create a 2nd Stack Exchange account with a different email address to see if it was possible. I filled in the fields, successfully completed the RECAPTCHA, and nothing happened. The page reloaded, and I was given a new RECAPTCHA. I thought I had failed to prove I was human, so I tried again with the same result.

In the mean time, I received the "Complete Registration With Stack Exchange" email from Stack Exchange, so I thought it had worked, but when I clicked the link I was taken to a page that indicated that the page was not found:

Page Not Found on SE OpenID

Indicating that my attempt to create a 2nd Stack Exchange account while still logged into the first had indeed failed.

I went over to Stack Overflow to confirm the behavior with the old login system and when I tried to create a new Stack Exchange account while still logged into the first, I was redirected to the front page (suggesting that the system successful figured out I was logged in already and didn't need a new account).


TL;DR;

Steps to reproduce:

  1. Have an existing SE Login and be logged into it
  2. Try to create another new SE Login via Meta's new login page (this only affects meta at this time, other SE sites still use the old login page and are not affected)
  3. Enter your info, pass the captcha
  4. Page appears to reload and provides a new captcha
  5. You'll receive the "confirmation your address" email from SE
  6. If you try to confirm your address, you'll get a "page not found" page.

So I see 2 problems here:

  1. If I try to create a login and it fails, I should be given feedback right then and there.
  2. I should not be sent an email to confirm a registration that was not successful
  • There were a few bugs in the process that have been ironed out since you posted this - you shouldn't be seeing openid.se at all (well, a redirect or two, but those shouldn't be that noticeable) – Oded Feb 7 '14 at 19:47
  • @Oded thanks, I'll take a look and see if it happens again. – psubsee2003 Feb 7 '14 at 20:35
  • @Oded ok, worked better now - the account was actually created and I have 2 SE accounts now. But there is no feedback at all (success or failure) with the CAPTCHA. Is that expected, or should is that a new bug report? – psubsee2003 Feb 7 '14 at 20:51
  • There should definitely be feedback with an incorrect CAPTCHA - a correct one will simply go through (success means correct CAPTCHA). – Oded Feb 7 '14 at 20:57
  • @Oded it seemed to be successful (and I double checked the values twice before submitting), but the all the page did was give me another captcha and blank out my password. – psubsee2003 Feb 7 '14 at 22:12
  • Strange - will look into it. Thanks for taking the time to test. – Oded Feb 7 '14 at 22:15
  • @Oded if it is pertinent, I am using Windows 7 and the latest version of Chhrome (32.0.1700.107 m) – psubsee2003 Feb 8 '14 at 1:59
  • Thanks for the details - not sure it is important in this case, though. – Oded Feb 8 '14 at 7:50
  • @Oded FYI - someone is seeing virtually the same problem I am (I think). They opened a feature request to provide feedback which I think it ultimately the same problem I am having, but the bug that caused the error on OpenID.SE obscured the issue when I opened this bug report as I thought they were related – psubsee2003 Feb 9 '14 at 1:23
  • OK - found the bug and fixed it. Will be built out shortly. – Oded Feb 9 '14 at 11:23
  • @Oded Probably should [status-completed]'ify this question, then? – hichris123 Apr 2 '14 at 0:31
  • "shortly" 6 to 8 weeks – michaelb958 Apr 2 '14 at 8:34
  • @hichris123 this issue wasn't "status complete". In the end it was the same root issue but I was focusong on another problem that Oded couldn't reproduce. The question I linked is the problem that Oded did fix – psubsee2003 Apr 2 '14 at 8:36

You must log in to answer this question.

Browse other questions tagged .