1

I ran a query with the "text-only results" checkbox checked, and got around 50,000 results, seen here:

Zero rows returned bug pic

But if you look at the bottom right corner of that screenshot, you see it says "0 rows returned" - I know this is true, because it's just a blob text, but can we please have it say something like "X Rows Returned in Text"? This can be accomplished by checking all the \n's, I think.

2
  • 2
    Well, technically it didn't return any rows. It returned a blob of text.
    – animuson StaffMod
    Feb 1 '14 at 22:07
  • 1
    @animuson Then maybe it should say 'returned x rows of text
    – Cilan
    Feb 1 '14 at 22:08
5

This will probably be changed up anyway because I'm in the process of adding support for multiple result sets (in which case we'll likely just show the tables regardless of whether or not you also wanted text-only results), but for right now I've changed it to just say "Results returned in..." when the text-only option is checked to avoid confusion.

An issue where text-only results could sometimes produce an exception is now also fixed, pending a pull and redeploy.

4
  • What does multiple result sets mean? Are you adding more results than just text, normal, and CSV?
    – hichris123
    Feb 1 '14 at 23:47
  • 1
  • Well, there's still "(X row(s) affected)" in the end of the output, can't it be omitted when choosing text only? Feb 3 '14 at 11:54
  • 1
    @ShadowWizard That's accurate for those results, though, so I don't see any reason to remove it.
    – Tim Stone
    Feb 3 '14 at 13:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .