5

Somebody asked a question in the comments on the announcement post that is probably worthy of being a real question.

Why does the Stack Exchange app require iOS 7 and is incompatible with earlier versions?

(Personally, I am fine with this decision but I'm also curious what reason the powers that be will give.)

  • 3
    (Speculation) Because iOS 7 adds tons of new APIs, including the extremely useful TextKit, which makes dealing with rich text (e.g. Markdown) extremely easy. – Richard J. Ross III Feb 11 '14 at 0:40
11

Just like how our Android application only works on Android 4.0 and above, we decided to make our iOS application target 7.0 and above since it allows us to use the newest UI and design paradigms instead of dealing with older versions. We might lower that requirement later down the line but for now it's staying steady. We did this so that we could get the application out in time with our small team.

  • 4
    With 82% of devices accessing the App Store already using iOS 7, this seems like a smart choice by Stack. By the time the app exits beta that percentage will surely be even higher. – David Snabel-Caunt Feb 11 '14 at 11:45
  • I signed up for the beta, but I still have an iPhone 3GS (which goes only as far as iOS6), so I guess I'm out of the party. :( – Shoe Feb 26 '14 at 2:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .