2

Due to confusion in the way I previously worded this question, I am rewriting it for clarity and possible steps to reproduce

  • Received a push notification of a comment on my answer
  • Swiped to read comment, (launching app)
  • Switched tab from Answers to Question
  • Tried to upvote the question
  • Received error:

    You can't vote for your own post

Again, I tried to upvote a question to which I'd posted an answer but I did not ask the question.

This failed in the iOS app, but did work on the website.

Link to question: Continue to read in file after if statement


Edit: reproducable, now with screenshot:

You can just barely make out at the bottom of frame that the user I'm trying to vote on is not me! But I did get to this page via my answer.

6
  • provide us with the question you were trying to answer – Aniket Inge Feb 11 '14 at 4:20
  • @PrototypeStark edited question with link – mhlester Feb 11 '14 at 4:24
  • @mhlester did you downvote the question before trying to upvote? – user215192 Feb 11 '14 at 4:31
  • @Raghunandan, nope. I only tried to upvote, and only on the app. I just tried in browser and it worked. Definitely a problem exclusive to the app – mhlester Feb 11 '14 at 4:33
  • @mhlester if you feel its a bug or a you need to request a feature ask a question on metag with android-app tag. – user215192 Feb 11 '14 at 4:49
  • 1
    @mhlester I have seen this error previously, and this usecase should help me track it down... I'll post any updates once I find a fix. – Arie Litovsky Feb 11 '14 at 13:26
5

The problem was that, coming from the inbox, we only had an answer identifier available, without the corresponding question identifier . This was causing the voting logic to wrongly assume we need to upvote/downvote the answer instead of the question. That's why you were getting that error – the app was actually trying to upvote your own answer!

This has been fixed and will be available in tonight's build.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .